Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Missing Numbers on speedo (http://www.jeepgarage.org/f107/missing-numbers-on-speedo-64536.html)

johnsavarese 08-23-2013 04:23 PM

Missing Numbers on speedo
 
Tried searching on this subject but couldn't find anything. Has anyone else experienced this? Driving down the road and when I switch the speedometer from numbers on display to the traditional speedometer display, it is blank.

recoil1911 08-23-2013 04:54 PM

Yes. When I test drove and toggled over from the digital to analog display it was missing all of the numbers. When I got back to the dealership it magically started working again after the JCG was restarted. I chalked it up to a glitch and ended up buying the vehicle. I typically use the digital number read-out so I haven't noticed it since then.

Sent from my SCH-I905 using Tapatalk 4

Baalic 08-23-2013 10:02 PM

Quote:

Originally Posted by recoil1911 (Post 881337)
Yes. When I test drove and toggled over from the digital to analog display it was missing all of the numbers. When I got back to the dealership it magically started working again after the JCG was restarted. I chalked it up to a glitch and ended up buying the vehicle. I typically use the digital number read-out so I haven't noticed it since then.

Sent from my SCH-I905 using Tapatalk 4

not noticed this myself but i wish the analog went by 10's instead of 20's.... wish they would fix that..

vnbWK2 08-24-2013 06:06 AM

Glad I'm not the only one. This happened a couple of times in my Limited. The first time it happened while I was driving and while switching back and forth a couple of times from digital to analog. Magically reappeared a few minutes later. Second time it happened while I was parked listening to some music at my jobs parking garage. Switched back as forth and analog went blank. Restarted the jeep and it came back. Glitch.

Willx 08-24-2013 06:08 AM

Re: Missing Numbers on speedo
 
Quote:

Originally Posted by vnbWK2 (Post 881550)
Glad I'm not the only one. This happened a couple of times in my Limited. The first time it happened while I was driving and while switching back and forth a couple of times from digital to analog. Magically reappeared a few minutes later. Second time it happened while I was parked listening to some music at my jobs parking garage. Switched back as forth and analog went blank. Restarted the jeep and it came back. Glitch.

There is a Star Case on the cause of this... Your Service advisor can seach "Speedo (Speedometer) drop out"

johnsavarese 08-24-2013 03:43 PM

Re: Missing Numbers on speedo
 
1 Attachment(s)
Thanks a lot for the Star case information. I appreciate it.

If anyone doesn't understand what I am talking about or if you want to see it, I've attached a picture. It's a little blurry cause I was trying to take it quickly, but you can see the numbers are missing from the speedometer.

Willx 08-24-2013 04:04 PM

Quote:

Originally Posted by johnsavarese (Post 881765)
Thanks a lot for the Star case information. I appreciate it.

If anyone doesn't understand what I am talking about or if you want to see it, I've attached a picture. It's a little blurry cause I was trying to take it quickly, but you can see the numbers are missing from the speedometer.

Yes that is exactly what happens with the one issue. They need to check a CAN Bus connector to see if that is the problem.... if that is not the issue, they will need to diagnose further.

vnbWK2 08-24-2013 05:30 PM

Re: Missing Numbers on speedo
 
1 Attachment(s)
Quote:

Originally Posted by Willx (Post 881772)
Yes that is exactly what happens with the one issue. They need to check a CAN Bus connector to see if that is the problem.... if that is not the issue, they will need to diagnose further.

Thanks Willx. What would be involved in checking the CAN Bus connector? I don't know if I want them taking apart part of the dash. I can probably live with it.

Here's a pic of mine.

Willx 08-24-2013 09:22 PM

Re: Missing Numbers on speedo
 
Quote:

Originally Posted by vnbWK2 (Post 881809)
Thanks Willx. What would be involved in checking the CAN Bus connector? I don't know if I want them taking apart part of the dash. I can probably live with it.

Here's a pic of mine.

First off you are clearly from Australia as you are driving the wrong way up....

Anyway, if this happens periodically, they really need to check it. This connector is pretty important and may cause other issues. If this happened once, I wouldn't worry but a CAN Bus connector with an issue can cause more serious issues. Kind of like a bad network cable on your computer, works ok some days, other days all hell breaks loose. It is on the right side of the Center consol stack. not hard to get at.

vnbWK2 08-24-2013 09:49 PM

Quote:

Originally Posted by Willx (Post 881938)

First off you are clearly from Australia as you are driving the wrong way up....

Anyway, if this happens periodically, they really need to check it. This connector is pretty important and may cause other issues. If this happened once, I wouldn't worry but a CAN Bus connector with an issue can cause more serious issues. Kind of like a bad network cable on your computer, works ok some days, other days all hell breaks loose. It is on the right side of the Center consol stack. not hard to get at.

Lol thanks. Dont know why my iPhone pics always upload upside down. I'll mention the CAN Bus to my service dept when I make my first oil change appt.

Willx 08-24-2013 09:54 PM

Re: Missing Numbers on speedo
 
Quote:

Originally Posted by vnbWK2 (Post 881953)
Lol thanks. Dont know why my iPhone pics always upload upside down. I'll mention the CAN Bus to my service dept when I make my first oil change appt.

just mention "my speedo drops out" if they can't find it spell s-p-e-e-d-o-m-e-t-e-r for them :lol:


All times are GMT -5. The time now is 04:51 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community