Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WJ (http://www.jeepgarage.org/f51/)
-   -   slight idle problem at startup (http://www.jeepgarage.org/f51/slight-idle-problem-at-startup-64825.html)

knightrider98271 08-30-2013 01:51 PM

slight idle problem at startup
 
Ok, let me see if I can describe this one.
Intermittently when I start my 02 4.0 Laredo it will fire up and be at 900-1000ish rpm, 2 seconds later is will go up to 1200 - 1300 then go right back down to 1000, and idle fine until warm up at 650 ish.
The idle doesnt fluctuate up and down more than the 1 time.
I removed and cleaned the IAC, and TB. I was thinking I might need a new fuel filter? might do it anyways just because she has 194,000 on her. I bought it at 192,000 and dont know the previous maintenance.
Anyone else ever run into this?

Frango100 08-30-2013 05:59 PM

Re: slight idle problem at startup
 
Could be the TPS which get old. If you have a scanner which shows live data, you could see if the TPS reading is steady or not.

knightrider98271 08-30-2013 07:30 PM

Re: slight idle problem at startup
 
Quote:

Originally Posted by Frango100 (Post 885228)
Could be the TPS which get old. If you have a scanner which shows live data, you could see if the TPS reading is steady or not.

I have the torque app, not really sure what I would be looking at, % of throttle? what should it be at startup?
help steer me in the right direction please :)

Frango100 08-30-2013 07:46 PM

Re: slight idle problem at startup
 
On my jeep its around 12% in idle, but i remember that a previous TPS had a slightly different value. Important is that it stays stable and doesn't fluctuate when you don't touch the accelerator.

Shift.91 08-30-2013 11:04 PM

Key on engine off, watch the tps % while slowly pressing the accelerator to the floor. It works nice if you can graph it. You should get a nice even reading and no sudden spikes in percentage. Mine had the same issue as you're having as well as it couldn't decide what gear to stay in while cruising. Replaced the TPS and it runs good as new!

knightrider98271 09-04-2013 10:55 AM

12.5% key on eng off. Not erratic when depressing petal. Doesnt seem to do it when its warn outside, usually just when its the first start when cool outside


All times are GMT -5. The time now is 05:53 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community