Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   WK Hemi 2005: Transmission problems (http://www.jeepgarage.org/f181/wk-hemi-2005-transmission-problems-64902.html)

asuricat 08-31-2013 12:42 PM

WK Hemi 2005: Transmission problems
 
My Jeep is driving me crazy. This morning it would not engage any gears. The selector moves and it shows on the dash which gear is selected but nothing happens. There is a slight change in revs when going from neutral to drive etc but that is all. The selector shaft on the gearbox moves and selects properly. The gearbox oil is almost full. There is an error code(p 0513) that says incorrect skim key that has something to do with the immobilizer and the smart key. Could this have something to do with the gearbox not selecting gears?
Please help!!

*sox* 08-31-2013 04:34 PM

Re: WK Hemi 2005: Transmission problems
 
Quote:

Originally Posted by asuricat (Post 885600)
My Jeep is driving me crazy. This morning it would not engage any gears. The selector moves and it shows on the dash which gear is selected but nothing happens. There is a slight change in revs when going from neutral to drive etc but that is all. The selector shaft on the gearbox moves and selects properly. The gearbox oil is almost full. There is an error code(p 0513) that says incorrect skim key that has something to do with the immobilizer and the smart key. Could this have something to do with the gearbox not selecting gears?
Please help!!


clean your shifter this can create diffrent issues.

Jeep Grand Cherokee Electronic Shift module cleaning video.wmv - YouTube

jeepgcoman 08-31-2013 08:42 PM

Re: WK Hemi 2005: Transmission problems
 
Excellent video, sox! Hope I never have to do it, but it I do, this will make it easier. Thanks for taking the time to enlighten us all.

hikelbum 09-01-2013 10:42 AM

Re: WK Hemi 2005: Transmission problems
 
Thank you sox. this is the highest quality repair video I have seen. Please make more.:thumbsup:

asuricat 09-02-2013 02:16 PM

Re: WK Hemi 2005: Transmission problems
 
Thanks for a gread video SOX. My gear indicators only have the brackets around the gear that is selected so I suppose that is not my problem. Any other ideas or suggestions?

jeepgcoman 09-03-2013 10:51 AM

Re: WK Hemi 2005: Transmission problems
 
Quote:

Originally Posted by asuricat (Post 885600)
This morning it would not engage any gears. The gearbox oil is almost full. There is an error code(p 0513) that says incorrect skim key that has something to do with the immobilizer and the smart key. Could this have something to do with the gearbox not selecting gears?

First, I don't believe the Skreem module would cause your problem. I may be wrong, but I don't think the engine would stay running if this were the problem. It would run for about 3 seconds and then die. Next, how low is the fluid level? Have you just had the transmission serviced? If so, who did it and how long ago? What kind of fluid was put in? Were the filters changed? Once we know all this, then we may be able to make more "uneducated" guesses as to what may be going on.

My initial thoughts are (if the fluid level is correct) that the pump is sucking air and you're not getting enough line pressure to allow it to go into gear. Could be split side on the main filter, a plugged cooler return filter (if it's the original) or, if filters have been changed , the main filter improperly installed. Anyway, once we know the answers to the above questions, it'll help......hopefully!!

asuricat 09-03-2013 02:28 PM

Re: WK Hemi 2005: Transmission problems
 
Quote:

Originally Posted by jeepgcoman (Post 886857)
First, I don't believe the Skreem module would cause your problem. I may be wrong, but I don't think the engine would stay running if this were the problem. It would run for about 3 seconds and then die. Next, how low is the fluid level? Have you just had the transmission serviced? If so, who did it and how long ago? What kind of fluid was put in? Were the filters changed? Once we know all this, then we may be able to make more "uneducated" guesses as to what may be going on.

My initial thoughts are (if the fluid level is correct) that the pump is sucking air and you're not getting enough line pressure to allow it to go into gear. Could be split side on the main filter, a plugged cooler return filter (if it's the original) or, if filters have been changed , the main filter improperly installed. Anyway, once we know the answers to the above questions, it'll help......hopefully!!

The fluid is just below the full mark. It has not been serviced in 20 000Km and the fluid was topped up about 5000Km ago with fluid bought from the agents. The transmission was functioning perfectly when I parked the jeep about two weeks ago.

reconssgj 09-03-2013 05:50 PM

Re: WK Hemi 2005: Transmission problems
 
sounds like it could be in need of the recall service. i believe this is one of the symptoms.

brentwoodkris 09-04-2013 08:47 AM

Re: WK Hemi 2005: Transmission problems
 
Info on the recall for those interested: Jeep Grand Cherokee WK - Recalls 2005-2006

jeepgcoman 09-04-2013 06:45 PM

Re: WK Hemi 2005: Transmission problems
 
Quote:

Originally Posted by reconssgj (Post 887110)
sounds like it could be in need of the recall service. i believe this is one of the symptoms.


Defect: A transfer case electrical failure may result in an unintentional shifting of the transfer case into the neutral position.

Consequence: If the vehicle shifts into neutral, it may roll away increasing the risk of a crash or personal injury

I think if this were the case, you could go out and push the vehicle with it in the shift lever in the "park" position. May want to try it, and if you can move it, get the recall done. If not.....time to keep looking.

asuricat 09-07-2013 06:12 AM

Still no luck with the gearbox. I have this morning discovered that the gearbox oil level stays exactly at the same level when idling in drive, neutral, park and with the engine switched of. Could this be the result of a split filter?

asuricat 09-07-2013 06:13 AM

The transmission stays in park when park is selected.


All times are GMT -5. The time now is 12:39 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community