Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Export Grand Cherokee 2011+ (http://www.jeepgarage.org/f190/)
-   -   Rear 12 volt power outlet not working (http://www.jeepgarage.org/f190/rear-12-volt-power-outlet-not-working-64949.html)

Twscoot 09-02-2013 06:08 AM

Rear 12 volt power outlet not working
 
Hi all. (Reposted here)
I've got a Australian delivered CRD MY14 WK2 JGC which otherwise has been fabulous for the month I've owned it.
Tried to use the 12 volt accessory plug (in the rear cargo/boot compartment) yesterday and it has no power. Tried several accessories to no avail. Multimeter showed no power too. Fuse ok and I tried it in both positions for on all the time and accessory position only. Any suggestions before I go back to the dealer?
Cheers.

Scottina06 09-02-2013 08:32 AM

Re: Rear 12 volt power outlet not working
 
was the truck running?

Twscoot 09-02-2013 06:10 PM

Yes it was.

allypally 09-02-2013 08:47 PM

Re: Rear 12 volt power outlet not working
 
Go back to the dealer. maybe the plug has come loose, or never connected.

BobT 09-02-2013 09:01 PM

Re: Rear 12 volt power outlet not working
 
1 Attachment(s)
Quote:

Originally Posted by Twscoot (Post 886237)
Hi all. (Reposted here)
I've got a Australian delivered CRD MY14 WK2 JGC which otherwise has been fabulous for the month I've owned it.
Tried to use the 12 volt accessory plug (in the rear cargo/boot compartment) yesterday and it has no power. Tried several accessories to no avail. Multimeter showed no power too. Fuse ok and I tried it in both positions for on all the time and accessory position only. Any suggestions before I go back to the dealer?
Cheers.

I would prise off the rear quarter panel to see if one of the leads has come off but that's me, you may be more comfortable having the dealer do it. I've attached trim removal instructions. It's for an MY11 but it should be pretty similar. I'd advise getting a plastic trim removal tool. There are plenty on fleebay.

Twscoot 09-03-2013 08:08 PM

Thanks Bob.

Twscoot 09-13-2013 06:57 AM

Re: Rear 12 volt power outlet not working
 
Closing the loop on this thread. Loose plug was the problem. Dealer fixed it when they installed my rear camera today.


All times are GMT -5. The time now is 07:16 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community