Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK2 - (http://www.jeepgarage.org/f73/)
-   -   Hemi code... (http://www.jeepgarage.org/f73/hemi-code-65251.html)

mstordahl 09-09-2013 04:09 PM

Hemi code...
 
Today was the third time in as many weeks that the new jeep turned on the check engine light and the p0307 code (cylinder 7 misfire) upon cold startup. Till now this new jeep has been flawless, haven't seen any other ones doing this, just wondering is this something anyone else has experienced?

Will be taking into the dealer now for this, one time codes do not bother me, I am a HD mechanic, but once they get repetitive it needs to be repaired.

Thanks!

mstordahl 09-10-2013 08:12 PM

Re: Hemi code...
 
Nobody have any similar issues?

mstordahl 01-23-2014 06:06 PM

Re: Hemi code...
 
Im gonna bring this one up again, sorry.

Been to the dealer 3 times now and each time they re flash the computer with new software and say its fixed... check engine light comes back on within a few days again. Now it is always a P0300 code, random missfire.

This is really starting to p!ss me off, has anyone else had this issue with a new hemi?

Thanks.

robpp 01-23-2014 06:21 PM

Re: Hemi code...
 
when the 6 cylinders used to get that code it was a bad head.

if you been back for the same issue more than once this time INSIST on a resolution. Its OBVIOUSLY more than software.

older hemis it usually means a dropped valve or seat.

tomk 01-23-2014 06:35 PM

Re: Hemi code...
 
You service department needs to open a Starcase.

I have to say I haven't heard this one before. What is your build date (the "MDH" code on your door sticker)

sid_be 01-23-2014 07:08 PM

Re: Hemi code...
 
my GC summit with 5000 miles on it has done it 3 times.
The first time the engine light came on with code P0300.
Went to the dealership , they reset the code , did not have a solution for it.
Happened twice since , this time the engine light went out after a couple miles of driving.
So far only happens in the morning when i start the motor and put it in reverse.
The motor rpm's drop for a 1/2 second and the engine light comes on.(feels like its robbed of fuel)
I will go to the dealer if the engine light stay's on again.

mstordahl 01-23-2014 09:02 PM

Re: Hemi code...
 
Quote:

Originally Posted by sid_be (Post 964454)
my GC summit with 5000 miles on it has done it 3 times.
The first time the engine light came on with code P0300.
Went to the dealership , they reset the code , did not have a solution for it.
Happened twice since , this time the engine light went out after a couple miles of driving.
So far only happens in the morning when i start the motor and put it in reverse.
The motor rpm's drop for a 1/2 second and the engine light comes on.(feels like its robbed of fuel)
I will go to the dealer if the engine light stay's on again.

Exactly what mine does, almost. Mine does it on cold startup as well, and the light will go out on its own after a few key cyles but doesnt have to be in gear to do it. It will stumble for a second and then run perfect.

It is very infuriating for me, Im a mechanic for a living so I know they are just not putting any effort into it. Even when the light comes on, it is not running rough at all, and day to day it runs great.

I will get the build date tonight and post it up, its an early one I know that...

padgett 01-23-2014 09:35 PM

Re: Hemi code...
 
307 Could just be a bad/clogged injector. If it were mine I'd be tempted to swap injectors with another cyl. and see if it follows. Could also be secondary ignition (plug/coil). If it only happens after a cold start, I'd check for a partly fouled plug. How much of the misfire can you feel ?


300 is more problematic but I'd check the fuel rail pressure first, could be a bad pump/regulator.

Might not be a high tech problem at all.

agonzo 01-23-2014 09:48 PM

Re: Hemi code...
 
I have had the random misfire code twice in my 2014 hemi Durango (3000 miles now). After the second occurrence the dealer told me a software update will be available later in Q1 2014, starcase S130800468.

The light will go off automatically after about 15 restarts. I highly doubt it is a clogged injector or any other issue other than the software.

I am not worried about this. The hemi is a reliable engine. There is a thread in the Durango section about the same issue.

mstordahl 01-24-2014 08:28 AM

Re: Hemi code...
 
Mine is an 03/13 build date...


All times are GMT -5. The time now is 01:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community