Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   97 4.7 Grand Cherokee Immobiliser (UK Spec) (http://www.jeepgarage.org/f77/97-4-7-grand-cherokee-immobiliser-uk-spec-65274.html)

greekdave 09-10-2013 11:51 AM

97 4.7 Grand Cherokee Immobiliser (UK Spec)
 
Got an issue with the alarm/immobiliser in that the car is totally dead.

The problem started when I went to unlock the car using the remote key fob. This set the alarm off and it just kept going and going. Finally got the alarm to silence but then the car is totally dead. Tried disconnecting the battery for 10 minutes but this also did not work.

HELP PLEASE!!

bumpinjeep 09-10-2013 12:17 PM

Re: 97 4.7 Grand Cherokee Immobiliser (UK Spec)
 
The key doesn't work at all?

greekdave 09-10-2013 12:23 PM

Re: 97 4.7 Grand Cherokee Immobiliser (UK Spec)
 
Hi,
The key will lock and unlock the car but once in the ignition everything is totally dead.

bumpinjeep 09-10-2013 12:29 PM

Re: 97 4.7 Grand Cherokee Immobiliser (UK Spec)
 
Interesting. Sounds like it is either the battery or the immobilizer completely shut everything off. Do you have a dealer anywhere near you?

greekdave 09-10-2013 12:36 PM

Re: 97 4.7 Grand Cherokee Immobiliser (UK Spec)
 
Its got a brand new battery and all was working fine this morning.

bumpinjeep 09-10-2013 12:48 PM

Re: 97 4.7 Grand Cherokee Immobiliser (UK Spec)
 
You said that you checked the battery connections right? If that looks good then it has to be the immobilizer disconnecting everything. I would recommend contacting the dealer or you could go to www.Jeepsunlimited.com. JU is the best Jeep forum when it comes to ZJ/WJ vehicles.

Frango100 09-10-2013 02:39 PM

Re: 97 4.7 Grand Cherokee Immobiliser (UK Spec)
 
You have a ZJ with 4.7 engine?
Don't know the ZJ, but an immobilizer normally shuts down the engine when an invalid key is used, but will not prevent electrical power to the systems. Is nothing working (no lights, no seat operation?)
If really all is dead, I would check the battery voltage first, to be sure its not discharged. If ok, I would check the cables at the battery terminals and the grounding of the negative battery cable.


All times are GMT -5. The time now is 03:42 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community