Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   2011+ Dodge Durango-WD (http://www.jeepgarage.org/f177/)
-   -   My 2014 Citadel 3.6L AWD Sandstone/Tan review (http://www.jeepgarage.org/f177/my-2014-citadel-3-6l-awd-sandstone-tan-review-65586.html)

vertrkr 09-17-2013 01:44 PM

My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
3 Attachment(s)
2014 Durango Citadel 3.6L AWD Standstone, tan interior, Tech & Tow package and captains chairs with mini console.

I give it an A- grade right off the bat. It drives and feels more like a luxury car than I thought. Got a few minor gripes but overall very nice. Ok, here's my story.

Picked her up at the dealer and it had 9 miles on it. I got it for $43,385.26 before TTL. The dealer only tried to screw me out $500 which was my deposit they forgot to add in, "whoops" they said, ya right.

Most surfaces inside are soft to the touch, not much hard plastic you'd reach out and touch. I've only driven 30 city miles and it really felt like my Dad's '13 ML350, very luxurious. The ride is not too firm and not too floaty, just perfect for me. The tranny is ultra smooth. I could just barely feel the shifts in the lower gears and not at all above 3rd. I really like the rotary shifter, didn't think I would, very solid feel to it. The voice navigation worked like a champ. I hit the VR button and said "Navigate to 1249 Woodside drive, Danville, California" (not my real address). A few seconds later it was on the Nav screen and asked if I wanted to start. I tried a few more like "Find Starbucks" and presented a list of all the nearby Starbucks and I just say a number off the list and it puts in the directions. When starting up I'm really pleased not to have to hit an OK button to gain access to the screen. A warning and accept message comes up but goes away after a few seconds.

I got tons of leg & head room with the seat all the way down & back and I'm 6'4" 250lbs. The visibility is excellent all around and the blind spot monitoring is really cool. If someone is in the blind spot a yellow icon is in the mirror and if you turn on the blinkers it will chime at you although I find it a little conservative leaving a lot of room before the alert goes off. The collision mitigation system scared the crap out me. I had one false alert and its chime was quite loud and flashed BRAKE really big in the speedometer screen. I was on a slight curve with traffic in front of me when it went off. There are two settings for it, default if FAR so I set it to NEAR which will reduce the false alerts. I made a bluetooth call and its output is not thru the stereo speakers but thru 1 speaker on top of dash near the window. It was still very clear though and you could adjust the volume using the stereo volume dial. The other party said I was crystal clear and had no idea I was in the car let alone driving down the road.

I love the EVIC system, really enjoy having many choices to customize it. Currently I like have the digital speedo and the oil temp screen. I find myself scrolling thru the sub screen watching the oil/tranny temps & pressure. The ventilated seats are something I've always wanted and boy can you feel it when it's on high, really keeps you from feeling hot & sticky on your legs, butt and back.

I like the HID lights too. Bright and they have a good beam pattern. The high beams are HID too the best I can tell, there's no visible halogen bulb for the high beams I can spot. When starting up at night they do some sort of level check lowering and raising the beam. I'd like an articulating cornering feature but hey, can't have everything. The auto high-beam dim works really well so far. You flick the stalk forward to turn on the high-beams and when ever it sees a car in front of you, either coming at you or in your lane it immediately dims to low-beam.

I think Chrysler has a home run on their hands here. I'm impressed enough I'll buy a Town & Country soon as they put in the 8.4" uConnect screen, 7" EVIC screen and ZF tranny to replace our Odyssey.

Thanks to all the dedicated engineers, line workers, executives with foresight and alike who made this come together.



Gripes:
I find the seats quite firm and a little narrow for me. Seats in my Honda Odyssey and Ridgeline are much more comfortable.

The steering is just a little over boosted for my taste at slow speeds but not bad and not ridiculously over-boosted like the Mercedes ML/GL. I have no issue at higher speeds.

Uconnect bug, my version is 13.33.7. (1) In the settings menu for Driving/Safety section, changes only stick if the engine is running, other sections work fine when in ACCessory mode.

The sun roof gasket/seal isn't flush with the roof on the rear, sticks up about 1/8".

The cruise control on doesn't stay active after a restart and neither does the active cruise control. After every restart you have to turn them on again before you can hit the set speed button.

My steering wheel is slightly off center, just a degree or two to the right, debating if I want the dealer monkeys to rip it apart to get it true center.

I wish there was one or two more storage places up front, perhaps a fold out pocket on the side of the center console. I find myself with no place to put coin change.

In the EVIC display for oil/tranny temps/pressure you can only see one system at a time. I wish they'd use a smaller font and combine them all onto 1 screen.

Headlight Auto On/Off feature is way too sensitive and will turn on when it's still fairly light outside. Happens alot when driving thru shady areas when it's about an hour before sun down. Then they'll go off when out of the shade and back and forth. They always come on when pulling into my garage. Drives me nuts so much I had to take them out of Auto mode which makes me mad as I really want this feature. There's gotta be way to adjust the sensitivity/timing.

The rear view camera often stutters/lags just a little bit like a low bandwidth/frame rate internet video. It's not bad but usually can see just a little bit of jerkyness to it.

vertrkr 09-17-2013 02:00 PM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
1 Attachment(s)
One other issue I have is the Sun Roof isn't flush with the roof on the back side. The rubber seal on the back is sticking above the roof by an 1/8". Not sure if that's by design but I want to double check others before the rain season starts.
I double checked it's fully closed.

davewg 09-17-2013 03:07 PM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Quote:

Originally Posted by vertrkr (Post 895047)
I found a little Uconnect bug, my version is 13.13.7. In the settings menu I changed a bunch of settings at the dealer while it was running. At home I just hit the ignition button twice, not running the engine, and made some setting changes. The changes would stick for 5 seconds then revert to the previous setting. They only stuck if I made the changes while the engine was running.

Thanks for the overall impressions. I do like the Sandstone on the Citadel - the color looks dressed up by the extra chrome that trim. Great choice.

As for the UConnect bug, there is a more recent version available here in the VIP section that you can load up on your own. Might be worth a look at those threads.

fireman 09-17-2013 03:09 PM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Very nice. Thanks vertrkr! How do you like the color in person? I know you had some concerns initially. The navigation sounds very useful and easy to use. Sounds like that collision mitigation got your attention. I'm glad you like the rotary shifter - I was a little concerned about that. Good to know about the Uconnect bug.

Thanks for the review! :thumbsup:

Laureljoke 09-17-2013 05:02 PM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Your initial review was just great, and very informative. I think the color looks terrific in your pictures, especially with the chrome, and I hope you have no regrets at all about your choice.

Happy to read that the knob shifter feels solid and comfortable....I was hoping it wouldn't take long to get used to it. I'm hoping to attend a local Uconnect seminar, even if I have to hold it myself in my garage. Excited about all the bells and whistles after so few for so long....until they malfunction. What a resource this forum will continue to be for those less technologically inclined like me.

I'm looking forward to the blind spot assist feature....the collision avoidance, not so much after your description.:eek:

JoeyD 09-17-2013 09:05 PM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Thanks for posting your thoughts vertrkr! I agree with the others on the color...looks great with the citadel trim.

I've been keeping tabs on the uconnect VIP thread for a while and I see you chimed in over there. The next big release is supposed to be in "October" though its been delayed a few times now. Its supposed to be a pretty comprehensive update, and hopefully the will have the Durango version merged with it by release.

That auto week review mentioned wind noise on the highway...you notice anything out of the ordinary there?

vertrkr 09-17-2013 10:31 PM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Answering questions:

Had a typo, uConnect version is 13.33.7

Color in person is much better than pics, all about the lighting. Really pleased with it complimenting the chrome, no regrets now.

I've driven up to 60 mph and I hear little to no wind noise. I'm very sensitive to this as my last car had quite a bit requiring a new windshield and gasket seal causing the trouble, I was checking this very carefully.

Update: pulling the dip stick and oil cap off I swear I smelled a hint of gas. Not unusual as the piston rings are not fully seated yet I suspect so there is a little bit of blow-by (un-burnt fuel escaping out of the cylinder past the piston rings) leading to fuel dilution into the oil. Per the manual, after 60 miles, it suggests to do some full throttle acceleration from cruising speed which should help seal the piston rings in. I'm at 50 miles now, will probably do that real soon now.

agonzo 09-18-2013 12:18 AM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Love the color. I am jealous.

Regarding your concern about the slight smell of gas...when I was test driving new SUV's (Explorer, Acadia, Pilot, Infinity JX) I would always make a point to spend some time under the hood after driving. In each vehicle I did notice a funny smell that could be described as unburned fuel. I'm not sure if that is what is was - might have been burning oil, blow-by described, or something else. I know in most machine shops, any ferrous metal parts are given a light coat of rust preventative. Maybe there was some of this residual material on the engine or exhaust manfold. Personally I wouldn't worry about it.

BTW: did you get an extended warranty on yours? I am thinking I will be keeping my durango for a long time, and the extended warranty sounds like a good idea.

vertrkr 09-18-2013 01:48 AM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Quote:

Originally Posted by agonzo (Post 895403)
BTW: did you get an extended warranty on yours? I am thinking I will be keeping my durango for a long time, and the extended warranty sounds like a good idea.

Ya, I've been contacting 5 sites for a quote, I've heard from 3 out 5 so far and the best is $1,535 for a Max Care 7 year/ 70,000 / 0 deductible warranty. I'll post my results when I hear from all them and buy it.

davewg 09-18-2013 08:08 AM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Quote:

Originally Posted by vertrkr (Post 895054)
One other issue I have is the Sun Roof isn't flush with the roof on the back side. The rubber seal on the back is sticking above the roof by an 1/8". Not sure if that's by design but I want to double check others before the rain season starts.
I double checked it's fully closed.

I found this shot of a sunroof on another Durango. I think the seal looks pretty similar to yours.

http://www.cstatic-images.com/supers...6/47065/07.jpg

Scottina06 09-18-2013 10:53 AM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
wow.....Im not a fan of chrome....but it really sets off that color! Amazing!

vertrkr 09-18-2013 11:00 AM

Re: My 2014 Citadel 3.6L AWD Sandstone/Tan review
 
Quote:

Originally Posted by davewg (Post 895531)
I found this shot of a sunroof on another Durango. I think the seal looks pretty similar to yours.
http://www.cstatic-images.com/supers...6/47065/07.jpg

Thanks Dave, that's encouraging. Hopefully other owners will chime in too. It just doesn't seem like it has a good seal sticking up like that.


All times are GMT -5. The time now is 05:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community