Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   2014 hid fog issues (http://www.jeepgarage.org/f107/2014-hid-fog-issues-65691.html)

jeep5.7 09-19-2013 07:30 PM

2014 hid fog issues
 
I had a 8 month old voly h10 kit I had laying around so I bought new 4300k h11 bulbs from xd,it has a relay kit installed,everything is wired up fine,this is my issue every once and awhile the drivers and passanger side will shut off either one side or the other,also I shut off the headlights one time and the fogs shut off too,now the newest thing is I get a lot of flickering while driving,also I have double polarity meaning no matter how you have the wires blk/blk or white/blk it works the same,grounds and power is fine,if the lights shut off all I do is turn off then back on immediately and it comes back on,i reversed polarity back again and same thing,sometimes the light will stay on and never shut off,im frustrated,called xd and I stumped them,kit was fine when I removed it out of my 08,i don't have the canbus fix for the fogs but I do for the headlights,xd said one wasn't neccassary,please help jg

loveracing1988 09-20-2013 11:11 AM

Re: 2014 hid fog issues
 
I had the same issues with my wife's jeep's headlights, the error eliminators/ canbus fixes fixed that, so I would try that and see if it fixes it.

bumpinjeep 09-20-2013 02:36 PM

Re: 2014 hid fog issues
 
The reason why you dont need the CANBUS fix is because the relay doesn't go through your DRLs. I would recommend calling KB directly and explaining whats going on. They have good customer service and should be able to get this taken care of.

loveracing1988 09-20-2013 06:37 PM

I had the DRL 's disabled and they still flickered. It is the way it pulses the voltage to save power that causes them to flicker.

jeep5.7 09-21-2013 07:25 PM

Re: 2014 hid fog issues
 
I called them and blew there minds lol,theres so much going on its just a trial and error thing but I don't know where to start,its the double polarity thing I don't understand,its a pia to keep taking the bumper on n off,you can only get lucky so many times,been off 3 times already,but my question is this,how do I know if its a relay or ballast or fuse or what,i mean they work fine but either one side or the other randomly shuts off,and passanger side gets real bright then goes back to normal,connections are perfect,i guess im going to wait and save up for a new extreme kit.im lost

jeep5.7 09-22-2013 11:08 AM

Re: 2014 hid fog issues
 
can anyone help,suggesstions

Dark_Shadow_GC 09-22-2013 04:23 PM

Quote:

Originally Posted by jeep5.7 (Post 897646)
can anyone help,suggesstions

I have been having a similar issue where one side would not turn off. I would have to disconnect it from the battery or pull the fuse. Called KB and they said it was a bad relay and they are sending me a new one. From what you explain, it sounds like you need both relays replaced. But that's just my opinion. If it was the fuse of ballasts I would think the lights would not go on.

And I agree taking the bumper on and off is for sure a PITA. By the time this issue is fixed I'll be an expert at it, haha

jeep5.7 09-22-2013 06:06 PM

Re: 2014 hid fog issues
 
Quote:

Originally Posted by Dark_Shadow_GC (Post 897732)
I have been having a similar issue where one side would not turn off. I would have to disconnect it from the battery or pull the fuse. Called KB and they said it was a bad relay and they are sending me a new one. From what you explain, it sounds like you need both relays replaced. But that's just my opinion. If it was the fuse of ballasts I would think the lights would not go on.

And I agree taking the bumper on and off is for sure a PITA. By the time this issue is fixed I'll be an expert at it, haha

I agree with the bumper thing,be a pro at a body shop as long as there gc lol,i guess ill call xd again and see what they have to say,i forgot how long the warranty on volt kit is,not suree if the relays are covered

Dark_Shadow_GC 09-22-2013 06:11 PM

Quote:

Originally Posted by jeep5.7 (Post 897774)
I agree with the bumper thing,be a pro at a body shop as long as there gc lol,i guess ill call xd again and see what they have to say,i forgot how long the warranty on volt kit is,not suree if the relays are covered

I have the Xtreme kit on mine. It has a 3 year warranty. Mine came with relays so I'm guessing that is why it was covered. But good luck. Hopefully it is as simple as installing new relays.

Switchback 09-24-2013 12:42 PM

Re: 2014 hid fog issues
 
You may get more help if you post this in the right section, try the WK2 section. This section is for the WK model.

jeep5.7 09-29-2013 11:57 AM

Re: 2014 hid fog issues
 
ok so I disconnected the relays and went directly to factory wire harness like kb said to try,with engine off they work perfect but when I turn it on they strobe like a cop car literally I mean they strobe on n off left and right,wtf now im completely lost,should I try a canbus fix for the fogs?

loveracing1988 09-29-2013 12:04 PM

Yes, I told you to try those over a week ago...


All times are GMT -5. The time now is 05:19 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community