Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   2014 Overland and blank screen on replacement radio (http://www.jeepgarage.org/f107/2014-overland-and-blank-screen-on-replacement-radio-65748.html)

perruz 09-21-2013 07:48 AM

2014 Overland and blank screen on replacement radio
 
I had my radio replaced about a month ago when I got the ‘phone needs service’ message. Yesterday the radio went completely blank; I took it to the dealer and they said it needs to be replaced again.

Normally, I wouldn’t be concerned about this but we bought this Jeep for a cross country trip and are leaving on September 29yh. It is a 2014 Overland and only has 2k miles on it. The service department said they can’t guarantee the radio will be in next week. I asked about taking a radio from another Jeep if it doesn’t come in and he said no. I know he is only the service rep and can’t authorize that and I would have to talk to someone higher up at the dealership, but I figured I would ask anyways.

I called Chrysler to see if they could expedite the shipment and started a file number on it. They told me to contact the dealership on Tuesday to see if they have an arrival date and if not they would look into it.

We are not taking the trip with a blank screen, so any other advice would be appreciated.

Thanks Joe

NEM835 09-22-2013 08:56 PM

Just my two cents but I would not take one out of another vehicle on the lot unless it was version 13.31.6. Mine was replaced and the dealer had it in three days. I have not had any problems so far with version 13.31.6 and if you get one out of another vehicle you risk just having the same problems and having to wait for the update to be released for the masses.

jacko15 09-22-2013 09:27 PM

Re: 2014 Overland and blank screen on replacement radio
 
I don't think they can take one out of another vehicle and put it in your Jeep. I believe it has to be set with your vin at the factory. I read this somewhere on another thread.

perruz 09-23-2013 04:46 AM

Re: 2014 Overland and blank screen on replacement radio
 
Thanks for the replies, my replacement had version 13.31.6 and it was working fine. I guess it might be a coincidence, but the day before I had the flash for the HVAC, transmission and another one.
My first replacement took about 3 days, but the dealer told me there might be a back order on them now so that’s why I was concerned.
Jack015, that makes sense, hopefully it won’t be an issue.


All times are GMT -5. The time now is 03:56 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community