Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Lost cruise control after TSB flash... (http://www.jeepgarage.org/f107/lost-cruise-control-after-tsb-flash-66170.html)

erikgenerik 10-02-2013 01:44 AM

Lost cruise control after TSB flash...
 
So I went today to have my '14 grand cherokee limited flashed with the TSB to fix the auto start AC issue. I used CC on the way to the dealership and on the way home I noticed that the CC would no longer turn on. I'd hit the button and the little speedometer wouldnt pop up in the cluster and CC would not function...crazy huh? On the up side, the AC now works with auto start! Gonna call the dealership in the morning and see what they can tell me. Anyone else have this issue?

TurboRush 10-12-2013 01:04 PM

Re: Lost cruise control after TSB flash...
 
I think I have run into the same issue... were you able to get the cruise control issue resolved?

erikgenerik 10-13-2013 07:17 PM

Re: Lost cruise control after TSB flash...
 
I haven't had a chance to get back to the dealership to get it fixed yet. They said I'd have to drop it off and leave it for the day (possibly) and I just don't have the time do that yet. I'm not planning a trip anytime soon so I don't need it right away but it would be nice to have it fixed. When I called the stealership they said they'd never heard of that problem. Did you ask your dealer about it? If so what'd they say?

Jecko33 10-13-2013 08:51 PM

In the same boat. Don't know exactly when I lost it, either after AC fix or new update. I reflashed 13.38.52 and it is still not working.

TurboRush 10-14-2013 07:47 AM

Re: Lost cruise control after TSB flash...
 
I just had the flash done on Saturday and noticed it afterwards. They screwed up on the update of the uConnect and only bumped me to 13.19 instead of the latest version. I am going to upgrade myself and see if that fixes it, if not I'll mention it when I get my next oil change.

I did some searching and the only other person I saw with this issue had the cruise control switch replaced. Not sure how they are related but either the HVAC update or uConnect upgrade, but....

jacko15 10-14-2013 10:49 AM

Re: Lost cruise control after TSB flash...
 
Could just be a coincidence. I did the Uconnect update a week ago, and on a 300 mile road trip this weekend, the cruise worked just fine. Hope you guys can get this resolved. I know I use my cruise quite a lot, and would miss it a bunch.

robertrichhart 10-15-2013 06:32 PM

Re: Lost cruise control after TSB flash...
 
Just back from the local dealer after restoration of our cruise control! Dealer had flashed the uconnect upgrade last Friday and after picking up vehicle we noticed that cruise control did not work at all. Called the dealer on Monday and took the GC in for them to resolve. They called me an hour later and said Chrysler told them to disconnect the battery and connect the leads for a short period, then reconnect. Cruise control is back!

TurboRush 10-16-2013 08:26 AM

Re: Lost cruise control after TSB flash...
 
I might be having a dumb moment here... ok, no might about it, what did they mean by connect the leads after disconnecting the battery?

robertrichhart 10-16-2013 07:01 PM

Re: Lost cruise control after TSB flash...
 
My understanding is that they removed the battery leads and touched them together which allowed any residual current to drain out of the radio or other electronics in the vehicle. That allowed a complete reboot for all electronics when the battery was reconnected and the vehicle was started again for the first time...

TurboRush 10-16-2013 07:19 PM

Re: Lost cruise control after TSB flash...
 
Ahhhh yes that makes sense, thanks for clarifying. Week give that a shot as soon as I have a chance.

Jecko33 10-20-2013 06:30 PM

Worked for me too!

5.7 My Hemi 10-20-2013 06:56 PM

Re: Lost cruise control after TSB flash...
 
Thanks robertrichhart, I think this is very good information for a lot of people to keep tucked in the back of their mind when they more than likely will have to do more updates. Thanks again.


All times are GMT -5. The time now is 09:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community