Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f155/)
-   -   Factory rear-view camera install in 2011 Laredo (http://www.jeepgarage.org/f155/factory-rear-view-camera-install-in-2011-laredo-66350.html)

WickedXJ 10-06-2013 10:18 PM

Factory rear-view camera install in 2011 Laredo
 
Hi guys

So I have(had) a pretty much base laredo, bought a 430n from a wrecked 2011, works great. Today I almost completed the installation of the factory rear view camera. The pdf instructions regarding wiring were vague to say the least.

Before I have the dealer update my GC or buy a lockpick can anyone who has installed confirm I wired it correctly? 430n does not recognize it all.

The stereo end- I used the existing harness and installed the 3 bare wires.
http://i608.photobucket.com/albums/t...ps82eae9c9.jpg

The camera end. I unplugged the factory plug to camera and used the one provided. In this pic I did not yet install the ground.
http://i608.photobucket.com/albums/t...ps3b4d8e17.jpg

Here you can see the factory plug I did not use.
http://i608.photobucket.com/albums/t...ps8d77ea6a.jpg

I drew power from the cigarette lighter
http://i608.photobucket.com/albums/t...psb2eccee6.jpg
Besides someone confirming I wired it correctly, any way to confirm before the reflash or lockpick?

Thanks in advance!:)

xJoshxx 10-06-2013 11:54 PM

Re: Factory rear-view camera install in 2011 Laredo
 
http://site.justforjeeps.com/guide/82212110.pdf did you use these instructions?

WickedXJ 10-07-2013 08:12 AM

Re: Factory rear-view camera install in 2011 Laredo
 
Quote:

Originally Posted by xJoshxx (Post 905222)
http://site.justforjeeps.com/guide/82212110.pdf did you use these instructions?

Yes those are the instructions I used, page 5 specifically, does not tell you to use factory C3 connector, there was one included that I didn't use, and no clear information anywhere about using the provided rear camera plug and bypassing the factory one, just was is said in step 17.

Have you installed one?

Going to call the dealer today and see what they charge to update the vin...

Of course when the camera is working I will create a step by step, have lots more pictures

eibyer 10-07-2013 10:55 AM

Re: Factory rear-view camera install in 2011 Laredo
 
There was another thread that had the issue with the connector, I will see if I can find it.

WickedXJ 10-07-2013 12:02 PM

Re: Factory rear-view camera install in 2011 Laredo
 
Quote:

Originally Posted by eibyer (Post 905432)
There was another thread that had the issue with the connector, I will see if I can find it.

Thanks- my searches came up with one guy who had to bring it to the dealer in the end- nothing with any pics though.

Dealer seemed to be pretty on the ball. Quoted me 60-120$. Think I will just go this route as soon as I'm confident its installed correctly.

eibyer 10-07-2013 12:51 PM

Ok, that is definitely cheaper than a lockpick. :-)

Milous 10-07-2013 01:05 PM

Re: Factory rear-view camera install in 2011 Laredo
 
Quote:

Originally Posted by WickedXJ (Post 905326)
...page 5 specifically, does not tell you to use factory C3 connector, there was one included that I didn't use...

Page 15: "NOTE: Install the radio to power source harness into the existing C3 radio (connector) if equipped, if not use the kit supplied C3 connector."

WickedXJ 10-07-2013 01:50 PM

Re: Factory rear-view camera install in 2011 Laredo
 
Quote:

Originally Posted by Milous (Post 905521)
Page 15: "NOTE: Install the radio to power source harness into the existing C3 radio (connector) if equipped, if not use the kit supplied C3 connector."

Okay, busted, that is pretty clear, I guess became I'm an electrical newb, not used to this kind of stuff, I doubt my abilities. But you can't argue that there is no mention of unplugging the factory harness on the camera and using the one provided, and unlike the C3, there is no diagram of wiring locations. There is a diagram of the factory connector however, which you don't need, or like I said, I made a grave mistake.

Anyway going to assume I did it right, will schedule appointment, then will make a new thread with all my pictures for anyone who could use it.

Milous 10-08-2013 05:00 PM

Re: Factory rear-view camera install in 2011 Laredo
 
Quote:

Originally Posted by WickedXJ (Post 905563)
But you can't argue that there is no mention of unplugging the factory harness on the camera and using the one provided, and unlike the C3, there is no diagram of wiring locations.

More often than not, Mopar instructions leave a lot to be desired. Post pics when your done, would like to add some to the WK2 site.


All times are GMT -5. The time now is 08:00 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community