Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Do any folks with 2014 Larado's have ECO Mode complaints (http://www.jeepgarage.org/f107/do-any-folks-with-2014-larados-have-eco-mode-complaints-66470.html)

mswlogo 10-09-2013 02:17 PM

Do any folks with 2014 Larado's have ECO Mode complaints
 
One or two folks with Larado's here have said they have no issues with Eco Mode.

I'm being careful to not say "Transmission" problem. But that's the topic I'm talking about. You'll see why in a second.

I'm wondering if the problem is somehow related to the Dual Exhaust.

The Dual Exhaust sounds completely different and the engine might be tuned different for it.

The ECO Mode problem feels more like how the Engine is poorly "Tuned" in some scenarios way more than poor "Shift Points" which people keep pointing at.

So I'm curious first, are there statistically as many complaints about the ECO mode performance on the Larado exhaust vs the Dual Exhaust of the Limited and up.

One other thing that could be happening is the car feels likes it's "Racing" (i.e. kicking down too far) more with a louder dual exhaust. It literally sounds like a drag racer when it does this over downshift thing. Where it might not feel so eventful on a much quieter exhaust.

Just a thought.

SoulStealer 10-10-2013 01:09 PM

I have a rough shifting 14 laredo with the v6

mswlogo 10-10-2013 02:34 PM

Re: Do any folks with 2014 Larado's have ECO Mode complaints
 
Quote:

Originally Posted by SoulStealer (Post 907886)
I have a rough shifting 14 laredo with the v6

Thanks for your input.

Can you describe what rough shifting means to you? I think there is more than one issue going on.

Some people describe a problem where you accelerate briskly, let up on the gas and perhaps it sees it can skip a gear. And when it goes in, you get a Clunk. Some people get that clunk as it downshifts when your rolling to a stop. This sounds like a mechanical (e.g. syncing gears) issue and sometimes confused with other undesirable behaviors. And for folks with this issue taking it out of Eco mode does not help. Still could be a software issue though. I suspect later build models don't have the "Clunk" issue. Not sure if that is due to mechanical change or intermediate better firmware from the factory. And I don't think it's trim level dependent. I personally have never seen this problem on my later build limited.

The issue I'm referring to in the first post strictly the ECO Mode behavior. Where it will Lag, sometimes quite a lot as you gently accelerate from a stop. If you ask for more power, it lags further. Then you ask for more and it downshifts A LOT and suddenly your head whips back and you're on someone's butt. Some might call this "rough shifting". I don't. Because the transmission it self does this thing with grace. Taking it out of ECO mode reduces this problem 95%. When it goes into this aggressive downshift it tends to want to stay there after you let off the gas much longer than feels right. Eventually it will. Pressing the gas modestly will bring the gear back up faster than just waiting with no pedal. This really feels like a software issue. It can vary a lot because what your transmission has "adapted" I think greatly effects it. I'm suspecting might be trim level dependent (i.e. Dual Exhaust or not). Like perhaps the Larado single exhaust tuning is being using on the dual exhaust models. With such major exhaust different I can't imaging the tuning with be identical. It might be handled through "Adaptive" process. But the Larado adapts better. I do have this problem on my limited even after the recent TSB.

argue4u 10-10-2013 03:34 PM

Re: Do any folks with 2014 Larado's have ECO Mode complaints
 
I have a V6 limited, but I had all the problems you mention intermittently. Took it to the dealer and there is a flash update that is supposed to fix the problem. It was substantially better after they flashed it but seems to be getting worse again a few months later (now). I've heard others have fixed the problem by removing the battery terminals for a period of time and then reconnecting. Many Jeep dealers like to tell you that it is just the characteristic of a Jeep, I disagree.

My favorite response of theirs to fix it: "just deactivate the ECO mode every time you start the vehicle."

mswlogo 10-10-2013 06:48 PM

Re: Do any folks with 2014 Larado's have ECO Mode complaints
 
Quote:

Originally Posted by argue4u (Post 907992)
I have a V6 limited, but I had all the problems you mention intermittently. Took it to the dealer and there is a flash update that is supposed to fix the problem. It was substantially better after they flashed it but seems to be getting worse again a few months later (now). I've heard others have fixed the problem by removing the battery terminals for a period of time and then reconnecting. Many Jeep dealers like to tell you that it is just the characteristic of a Jeep, I disagree.

My favorite response of theirs to fix it: "just deactivate the ECO mode every time you start the vehicle."

I know what Limited's do. I have one. I'm curious if Larado's have the same Eco Mode only issue.

LaberoC 10-10-2013 07:27 PM

I hate eco mode always turn it off unless im cruising on the freeway...dont really know what the problem is but it just really feels like its struggling too much probably cuz of all the hills

LaberoC 10-10-2013 07:28 PM

That and the shifting is really rough sometimes...still havent done the flash but from what I read its not really helping much

mswlogo 10-10-2013 08:58 PM

Re: Do any folks with 2014 Larado's have ECO Mode complaints
 
Quote:

Originally Posted by LaberoC (Post 908125)
That and the shifting is really rough sometimes...still havent done the flash but from what I read its not really helping much

And you're driving a Larado?

You should set your Model Year and Trim Level in your profile.

1quick1 10-10-2013 09:00 PM

Re: Do any folks with 2014 Larado's have ECO Mode complaints
 
ECO seems to shift hard sometimes because it's always trying to keep it under 2k rpm's so you need to speed up a bit but you're going 36mph in 7th gear at 1300rpm so it violently downshifts. ECO mode off is much better. Even better is sport mode but it really holds those gears long so it's not too practical for day to day.

LaberoC 10-10-2013 10:03 PM

Quote:

Originally Posted by mswlogo (Post 908204)

And you're driving a Larado?

You should set your Model Year and Trim Level in your profile.

Yeah laredo...will do

mswlogo 10-10-2013 11:27 PM

Re: Do any folks with 2014 Larado's have ECO Mode complaints
 
Ok, thanks. It sounds like Lorado's are no different.

f1anatic 10-13-2013 09:12 AM

Re: Do any folks with 2014 Larado's have ECO Mode complaints
 
Well, I do not have a Larado but I am thinking you should ensure that your Lorado gets all the applicable reflashes to transmission and engine. I can't speak for the Laredo, but on the Limited, there have been at least 2 engine and 2 transmission control module reflashes which transformed the car.


All times are GMT -5. The time now is 12:08 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community