Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio, Video, Navigation & Electronic Modifications (http://www.jeepgarage.org/f50/)
-   -   HID install in WJ (http://www.jeepgarage.org/f50/hid-install-in-wj-6653.html)

mrjaydeeone 02-17-2010 07:21 PM

HID install in WJ
 
I had some troubles with an HID kit that I had in a previous car that I couldn't get to work in my GC. At any rate I determined the kit was most likely crap and wasn't going to work.
I received new HID kit yesterday from DDM tuning. I hooked up with relay and they didn't turn on.
I tried without the relay and they turned on just fine.
I had tried one side and it worked and then the other side and it worked and then both together and they both worked. Here's the problem. Each time I turned on the lights I didn't have the jeep running. When I left for work the jeep didn't start. I was unable to troubleshoot as I didn't have enough time. I am hoping I just drained the battery temporarily and nothing is causing a constant drain. But I will see tomorrow when I jump.
Any ideas?

206WJ 02-17-2010 07:44 PM

Re: HID install in WJ
 
Did the battery drain with the relay hooked up, or was the relay un-hooked?


It takes a good amount of drain for my WJ to not be able to start. I run my 1500w stereo system and my OBA with the engine off and it starts right up.

mrjaydeeone 02-17-2010 08:04 PM

Re: HID install in WJ
 
it drained without the relay inline.
I also had an instance when I was hooked up my headunit and I kept testing the sound out, and just turned the jeep on not running and after a while I wasn't able to start the jeep, but after a few minutes of just waiting she started right up. hmm

206WJ 02-17-2010 08:06 PM

Re: HID install in WJ
 
That makes me think you have a very weak battery. When was it last replaced? Take it to an autoparts store and get it tested.

206WJ 02-17-2010 08:07 PM

Re: HID install in WJ
 
On a side note, I run my HID's without a relay. Only small issue is once every other month or so one of them won't fire right away and I have to turn the lights off and on once or twice to get to fire.

mrjaydeeone 02-17-2010 08:23 PM

Re: HID install in WJ
 
ah gotcha gotcha. Honestly I don't remember when it was last replaced. I bought the jeep December 31st. I have all the maintenance records for it. The battery is less then a year old I believe it was replaced last in May or June 09, or maybe it was 08. And the battery was replaced a few months before that also, as it was deamed defective.

mrjaydeeone 02-18-2010 07:30 PM

Re: HID install in WJ
 
well everything is okay now. I jumped the jeep when I got home this AM and it started right up. I brought it to mechanic to get battery and charging system tested (all was fine), just wanted to make sure I didn't wake to dead jeep when I had to go to work. Woke early started it and no problems, and then started right up again to leave for work.

Big Perm 04-02-2010 06:09 PM

Re: HID install in WJ
 
I run 3 sets in my jeep with no relays. no problems yet and the lows and fogs have been in for over 2 years.

mrjaydeeone 04-05-2010 07:40 PM

Re: HID install in WJ
 
damn forgot to update this post. I ended up with dead Jeep 2 days later. Bought a new battery and I have been good since.

caa0428 04-27-2010 04:48 PM

Re: HID install in WJ
 
Sorry for me being a little slow but you dont need a converter for the hid lights its direct plug and play(or see for that matter)

misfit77 04-28-2010 08:40 AM

Re: HID install in WJ
 
Stupid WKs...I need to use a relay for either high or low headlights.


All times are GMT -5. The time now is 06:45 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community