Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Here is a strange problem (http://www.jeepgarage.org/f107/here-is-a-strange-problem-67467.html)

Mashie 11-02-2013 05:51 PM

Here is a strange problem
 
Last week I got my Jeep back from the dealership after they replaced the fuel pump and TIPM which was the cause of the starting issues.

Now everything seems to be working fine except....

When I turn on the passenger turn signal, the signal in the side mirror and rear signal turns on, however instead of the front signal turning on, both fog lights blink?!

My guess is they switched some wires when installing the TIPM but before I head back to the dealership, I was wondering if anyone here had any ideas and if this was a possible easy fix?!

definitely a strange issue :eek::eek:

ernestd 11-02-2013 08:10 PM

Re: Here is a strange problem
 
I had my TIPM changed at 200 kilometers and everything worked fine.
The TIPM appears to be a series of motherboards stacked upon each other,so any one or all of those boards could be defective.Also keep in mind that there are several other computers on board of these cars that could also be the source of your issue.
I'm sure that a good technician can diagnose this issue properly and have you back on the road with a smile.
Cheers

rosado057 11-22-2013 09:33 AM

Happened to me as well. Found out tipm was refurbished and defective they need to install a new one. It's one piece they swap out just plug and play


Sent from my iPhone using Tapatalk

Wk-Hokie 01-14-2015 09:44 PM

Re: Here is a strange problem
 
We have the exact same thing. Had the TIPM replaced about a week ago and now the front fog lights and the left turn signal blink when we turn on the right turn signal. Left turn works fine. Hazards work ok except for right light. Taking it back to the stealer in the morning.


Sent from my iPad using JeepGarage

Joey.Donatelli 01-15-2015 02:43 PM

Re: Here is a strange problem
 
This is one of the stranger things I have heard about. let us know what the dealer tells you.

Good luck!!

Wk-Hokie 01-17-2015 07:57 AM

Re: Here is a strange problem
 
Dealer said that the new TIPM wires differently. They switched pins 7 and 11 and now it works great again. Hopefully that will be the last problem


Sent from my iPhone using JeepGarage

xj31 01-17-2015 10:45 AM

Here is a strange problem
 
The new TIPM comes with instructions in the box telling about rewiring. Sounds like someone missed that part


Sent from my iPad using JeepGarage


All times are GMT -5. The time now is 06:56 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community