Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f155/)
-   -   Stupid UConnect (http://www.jeepgarage.org/f155/stupid-uconnect-67869.html)

04blackz 11-12-2013 02:21 PM

Stupid UConnect
 
I'm having issues with my u connect and iphone. I'm not sure what's going on. It runs so slow, doesn't connect right half the time. And doesn't keep with with the album art and info. Problem happens with it being plugged in. I could understand Bluetooth being slow, but not with it plugged in. I'm not using the factory iphone cable but a Belkin one. I'm not sure if that matters. Anyone else have this problem?

lstowell 11-12-2013 02:35 PM

Re: Stupid UConnect
 
Quote:

Originally Posted by 04blackz (Post 929130)
I'm having issues with my u connect and iphone. I'm not sure what's going on. It runs so slow, doesn't connect right half the time. And doesn't keep with with the album art and info. Problem happens with it being plugged in. I could understand Bluetooth being slow, but not with it plugged in. I'm not using the factory iphone cable but a Belkin one. I'm not sure if that matters. Anyone else have this problem?

UConnect version current?
Done an upgrade recently?

You could try an official Apple cable, but if you can connect it to a workstation using the Belkin, can't imagine what UConnect would be worrying about.

04blackz 11-12-2013 02:44 PM

Yeah it was at the dealer about 3 weeks ago and they did a reflash and update on it. It's not registered with the uconnect yet cause of all the problems people were having. Idk what is wrong with it

*sox* 11-12-2013 02:45 PM

Re: Stupid UConnect
 
hi

which uconnect, which car??

lstowell 11-12-2013 03:51 PM

Re: Stupid UConnect
 
Quote:

Originally Posted by 04blackz (Post 929144)
Yeah it was at the dealer about 3 weeks ago and they did a reflash and update on it. It's not registered with the uconnect yet cause of all the problems people were having. Idk what is wrong with it

Caution that your dealer may not exactly be up to date on current releases, and may have flashed you to an older version.

Presuming this is the 8 inch with Nav, current is 13:38:52 NA or 13:39:51 International. You can check it from the apps settings button.

This is not to say thats the problem... as sometimes I think their website should be
www.stupiduconnect.com

04blackz 11-12-2013 04:54 PM

It's a 2014 grand Cherokee limited. And I'll check it later tonight and let y'all know.

GCLimited 11-12-2013 05:14 PM

Re: Stupid UConnect
 
I'm running version 13.19, and I still can't get my fiance's iPhone to work...even plugged in.

bill_de 11-12-2013 05:19 PM

Re: Stupid UConnect
 
Quote:

Originally Posted by GCLimited (Post 929280)
I'm running version 13.19, and I still can't get my fiance's iPhone to work...even plugged in.

So why don't you take a break from posting, and update your uConnect software. It might help.



---

lstowell 11-12-2013 05:59 PM

Re: Stupid UConnect
 
Quote:

Originally Posted by 04blackz (Post 929258)
It's a 2014 grand Cherokee limited. And I'll check it later tonight and let y'all know.

Check this out.
Jeep Grand Cherokee WK2 - Grand Cherokee Service Bulletins and Recalls

04blackz 11-12-2013 07:21 PM

Yeah I saw that. Interesting all the damn reflashes there are for this car. Looks like I'm gonna be taking a trip to the dealer now

wuaname 11-12-2013 10:30 PM

Re: Stupid UConnect
 
Sad that we all are having these uconnect problems . Seems like dodge didnt do enough testing b4 putting it out on the market never had that problem b4 with prior vehicles gps, electronics, etc then again they werent american brands.

Since this isnt a regular owner caused problem, or maintainance, is dodge providing a loaner car when you take it in for problems that they didnt fix b4 going into production or are you stuck with a rental car and costs bc jeep drooped the ball?

04blackz 11-12-2013 11:02 PM

Re: Stupid UConnect
 
Every time i've had to take it in for warrenty work, i get stuck with a rental/having someone pick me up. Psh jeep's too good for courtesy cars! Not impressed at all! So far I've had a new transmission gasket, then new tranny, then uconnect problems (got reflashed but still having problems) and a new oil pressure sensor put in, all with less than 7k on the clock...


All times are GMT -5. The time now is 12:34 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community