Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Zero Oil Pressure @ idle but ok when over 2000 rpm's (http://www.jeepgarage.org/f203/zero-oil-pressure-idle-but-ok-when-over-2000-rpms-6795.html)

MALLOPPO 02-21-2010 09:21 PM

Zero Oil Pressure @ idle but ok when over 2000 rpm's
 
Ok so all of a sudden today while driving slowly around an unfamiliar neighborhood my Jeep "Dinged" and check gauges light came on and i noticed the Oil Pressure gauge was @ ZERO ... so I immediately shut it off and checked oil level, which of course was fine... I noticed that over 2000 rpm's seems too have normal Pressure, about 40-50 on the Dashboard gauge. After it sat for about 45 minutes i started it up again and it was fine even at idle... a few minutes later stopping at a red light, and it drops again. Any idea if it actual a mechanical problem or maybe electrical issue with gauge or sensor?
It's a 1999 WJ Limited 4.7V8 AWD with 110,000 miles on it. :confused:

vicpick58 02-21-2010 09:59 PM

Re: Zero Oil Pressure @ idle but ok when over 2000 rpm's
 
Most likely it is just your sending unit, it is a fairly common problem with these Jeeps.

I had one fail on my 2000 Laredo 4.7 years ago. It is fairly easy to change out, I do not remember the size socket, maybe someone else can chime in with that.

I do remember that it took me longer to figure out the latch on the electric plug on the sending unit than it took to actually unscrew it and screw the new one in.

It is located just above the oil filter and it would be best to remove the oil filter and get it out of the way before you change the sender.

As long as you have plenty of oil and you are not hearing knocking when the pressure drops, it's probably your sending unit.

Joe in PA 02-21-2010 10:11 PM

Re: Zero Oil Pressure @ idle but ok when over 2000 rpm's
 
This is not something you really want to mess around with. It could be the sending unit or it could be the oil pump. Personally i wouldn't keep driving it until you figure out what it really is. Replace the sending unit first and see what happens. ;)

MALLOPPO 02-22-2010 12:59 AM

Re: Zero Oil Pressure @ idle but ok when over 2000 rpm's
 
K GUYS, thx for the fast replies ...
I'm going too try replacing the Oil Pressure Unit,
keeping my fingers crossed that it's not the actual pump ... or worse !!!


All times are GMT -5. The time now is 11:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community