Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f162/)
-   -   Radiator hose leak! (http://www.jeepgarage.org/f162/radiator-hose-leak-67994.html)

SRTBLK 11-15-2013 10:07 PM

Radiator hose leak!
 
Well I think this is a first. I was driving today and coolant started spraying out of drivers side hood vent onto windshield. I popped open the hood and saw the radiator hose rubbing against the spinning belt in the front of the engine creating the hole. it was readily apparent that the metal clip that is supposed to keep the radiator hose away from the engine doesn't work very well because the hose can be pushed toward the engine with ease!!! i would advise all of you to routinely check to make sure your clip is not loose and the radiator hose has plenty of clearance from the engine!!!

SRTBLK 11-16-2013 10:12 PM

Re: Radiator hose leak!
 
Apparently, at least one other person has had this problem on the red site and I have a feeling there will be more because if you check how easy it is for the hose to be moved, you will be surprised. when I get mine back, i am going to fashion a more permanent solution to this loose clip problem.

RN SHRRK 11-16-2013 11:04 PM

Re: Radiator hose leak!
 
We're you the one I saw at the Rancho Jeep dealership the other day? If not, then there is another person that had this happen.

Scottina06 11-17-2013 12:29 AM

Re: Radiator hose leak!
 
wow....that's crazy! Everyone run out to the garage and check asap!

SRTBLK 11-17-2013 07:28 AM

Re: Radiator hose leak!
 
Quote:

Originally Posted by RN SHRRK (Post 931474)
We're you the one I saw at the Rancho Jeep dealership the other day? If not, then there is another person that had this happen.

That makes three...lets see how many more SRTs have this problem before Chrysler has a permanent fix for this.

SRTBLK 11-17-2013 10:36 AM

Re: Radiator hose leak!
 
Quote:

Originally Posted by SRTBLK (Post 931565)
That makes three...lets see how many more SRTs have this problem before Chrysler has a permanent fix for this.

saw from other site that 2014's have a fix for it already, if anybody has a moment, could you take a picture of the clip above the fan shroud so i can see what the fix is? i was going to wrap the ends of the clip with a plastic tie to secure it better. thanks in advance

Scottina06 11-17-2013 10:51 AM

2 Attachment(s)
Heres a pic of the fix


Attachment 32037

SRTBLK 11-17-2013 10:48 PM

Re: Radiator hose leak!
 
thanks!

SRTBLK 11-23-2013 09:31 PM

Re: Radiator hose leak!
 
just an update, it was fixed under warranty and they fixed it with a new tighter clamp and plastic piece just like in the 2014's. very satisfied.

jim383 11-26-2013 03:14 AM

Re: Radiator hose leak!
 
Now thats weird as my 2012 early build (12 / 2011) already has that hose support as theres a peace molded on top of the fan shroud that the black hose support snaps into.

radbushi 11-26-2013 06:24 PM

Re: Radiator hose leak!
 
Quote:

Originally Posted by SRTBLK (Post 931039)
Well I think this is a first. I was driving today and coolant started spraying out of drivers side hood vent onto windshield. I popped open the hood and saw the radiator hose rubbing against the spinning belt in the front of the engine creating the hole. it was readily apparent that the metal clip that is supposed to keep the radiator hose away from the engine doesn't work very well because the hose can be pushed toward the engine with ease!!! i would advise all of you to routinely check to make sure your clip is not loose and the radiator hose has plenty of clearance from the engine!!!

Ty for the heads up i'll check that today.

radbushi 11-26-2013 07:24 PM

Re: Radiator hose leak!
 
Quote:

Originally Posted by jim383 (Post 936195)
Now thats weird as my 2012 early build (12 / 2011) already has that hose support as theres a peace molded on top of the fan shroud that the black hose support snaps into.

First I want to thank SRTBLK and second Jim383 look closer. Mine looks like the fix above but it can't be. It was 1/4 of an inch from the belt I slide it back but it doesn't lock in. I could have been stranded in BF Nevada going home to Idaho from Nor Cal this Christmas. It just slides back and forth on a track thingy. I will call my dealer tomorrow.
Thanks again SRTBLK!


All times are GMT -5. The time now is 02:52 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community