Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f155/)
-   -   2011 RHB: black NAV screen? (http://www.jeepgarage.org/f155/2011-rhb-black-nav-screen-68008.html)

Andrew Klossner 11-16-2013 03:44 PM

2011 RHB: black NAV screen?
 
2 Attachment(s)
After working flawlessly for two years, the NAV screen in my 2011 RHB now comes up black (see pic below.) All other screens are normal and the radio works. I pulled the M12 fuse for several minutes to reboot the head unit (and observed that the radio rebooted) but the NAV screen is still black.

Anything else to try before I take it to the dealer?

*sox* 11-16-2013 05:49 PM

Re: 2011 RHB: black NAV screen?
 
remove the radiofuse and then look.

why you have this old Software, why you have never update?

Andrew Klossner 11-17-2013 07:00 PM

Re: 2011 RHB: black NAV screen?
 
Quote:

Originally Posted by *sox* (Post 931364)
remove the radiofuse and then look.

Yes, I did that. The details are in my post.

Quote:

Originally Posted by *sox* (Post 931364)
why you have this old Software, why you have never update?

This is the older RHB from the 2011 model year. It's running the latest available software.

StaticFX 11-18-2013 07:38 AM

Re: 2011 RHB: black NAV screen?
 
You are on a very old version... RHB is up to 33...Sox knows his stuff ;)

New Software Update MyGIG RBZ-RB2-RHB / 33.01.23
http://www.jeepgarage.org/f155/new-s...3-a-51595.html

Andrew Klossner 11-18-2013 06:50 PM

Re: 2011 RHB: black NAV screen?
 
Quote:

Originally Posted by StaticFX (Post 932006)
You are on a very old version... RHB is up to 33...Sox knows his stuff ;)

New Software Update MyGIG RBZ-RB2-RHB / 33.01.23
http://www.jeepgarage.org/f155/new-s...3-a-51595.html

The TSR for that software update says it's for MY2012 only. My Overland is MY2011. I wouldn't want to load an incompatible ISO and brick my radio.

Yesterday, after five days of blank screen, the NAV started working again. I have no idea why.

*sox* 11-18-2013 07:04 PM

no issue for update, this unit are all the same, you can / musst updateting

go first with 33.23, then you can go with the last 50.00


.....with apple parts on tour

Andrew Klossner 11-19-2013 12:28 PM

Re: 2011 RHB: black NAV screen?
 
Quote:

Originally Posted by *sox* (Post 932295)
no issue for update, this unit are all the same, you can / musst updateting

go first with 33.23, then you can go with the last 50.00

Thank you.

Quote:

Originally Posted by *sox* (Post 932295)
.....with apple parts on tour

I don't understand this sentence. Would you kindly rephrase?

*sox* 11-19-2013 04:38 PM

Re: 2011 RHB: black NAV screen?
 
lol, this are my sig. on my ipad with tapatalk app:D

Justal13 11-21-2013 04:23 PM

Re: 2011 RHB: black NAV screen?
 
My dealer installed 55.00 on my 2012 GC a few weeks ago and it scrambled the radio. Luckily I had my disk with 33.23 in the glovebox. It took 3 trys, but we got the screens back to looking "normal". Neither fixed my u-Connect issues, so I have unpaired my phone so I can at lease use it while I am driving (otherwise, u-Connect would work - not work - work and drop my calls constantly). I REALLY hate the new Garmin GPS Black and White and shades of Grey screen graphics, very difficult to read. I much preferred the original multi-colored graphs.

The dealer told me then entered a Star Case, but I hold out little to no hope that my u-Connect will ever get fixed. Or that Chrysler will ever send out any real updates for the 430RHB radio (Gracenotes, etc). And every time I check on GPS updates, the Navtec site says "backordered" for the past 3 months. Wow, how tough is it to make some disks with software on them....Nevermind, I sometimes forget, this is Chrysler after all....

Andrew Klossner 11-22-2013 10:55 AM

Re: 2011 RHB: black NAV screen?
 
Thanks Justal13. I too have phone connect issues: sometimes the phone and head unit connect, sometimes they don't, with no rhyme or reason. For the first two years it worked solidly. It could be my phone, of course.


All times are GMT -5. The time now is 08:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community