Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Cherokee-SJ and XJ (http://www.jeepgarage.org/f19/)
-   -   weird electrical problem (http://www.jeepgarage.org/f19/weird-electrical-problem-68964.html)

4.whoa 12-09-2013 01:19 AM

weird electrical problem
 
I have a 95 Cherokee 4.0/auto/pwr win & locks. my control switches in the drivers door have not worked right for a while. when I took it apart I noticed the rubbery connector that plugs into the switches themselves was a little melted. also some of the switches were pretty bad. while I was tinkering with ( squeezing the connectors for a better grip on the pins ) it I think I may have shorted it somewhere. there was no spark but all the sudden the dome light, power windows, power locks ,& stereo all quit. I've checked all the fuses under the dash and under the hood 3 times. but I still have no power. it starts and runs fine. upon checking the extra terminals in the fuse block, I found only one battery and one ignition to still have power. for the time being I have used a jumper to go from the a mission that works to the ones that do not work to backfeed power for things to work. even doing that they're still are no power windows. I have several Cherokees and the older ones have the obvious fusible links over by the battery ,however I can't seem to find any on this. I haven't had any luck searching either.anybody have any ideas ?

I have replaced all the switches, but that hasn't helped either. None of the wires are touching


All times are GMT -5. The time now is 11:24 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community