Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   Shifting Issue (http://www.jeepgarage.org/f196/shifting-issue-69277.html)

DonG 12-16-2013 12:46 PM

Shifting Issue
 
Just returned from a 500 mile trip through snow and ice. At cruise speed (55-70) the engine keeps raising and lowering RPM @ 2K. Also feels like it's shifting to lower gear or out of overdrive.
When I disengage the overdrive, it does the same thing.
Is this a transmission issue?

Frango100 12-16-2013 01:58 PM

Re: Shifting Issue
 
Most probably the torque converter which releases and applies again. Did you check for any fault code set?
Most probably the TPS which is getting bad, but could eventually be a speed sensor as well. But the last one normally gives problems like harsh shifts.

DonG 12-16-2013 02:03 PM

Re: Shifting Issue
 
Shifts are smooth- do get a noise when this occurs when RPM increases but had that before.
No error codes or lights lit on dash.

Frango100 12-16-2013 02:47 PM

Re: Shifting Issue
 
I would try a new TPS first, or if you have a scanner which shows live data, you could check the TPS output (in%) and see if it fluctuates when the problem is there.

DonG 12-16-2013 03:04 PM

Re: Shifting Issue
 
Sorry Frank- TPS?

Frango100 12-16-2013 07:00 PM

Re: Shifting Issue
 
Throttle Position Sensor.

DonG 12-17-2013 08:43 AM

Re: Shifting Issue
 
Thanks Frank! Will get one today and let you know the results!

DonG 12-26-2013 09:13 AM

Re: Shifting Issue
 
Nailed it! Thanks Frank! Changed the TPS (in about 10 minutes) and it's running smooth as silk!
Happy Holidays!
Don G


All times are GMT -5. The time now is 07:43 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community