Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee SRT - WK2 (http://www.jeepgarage.org/f97/)
-   -   Window washer problem (http://www.jeepgarage.org/f97/window-washer-problem-69960.html)

salsfirst 01-04-2014 11:43 AM

Window washer problem
 
Is anyone else having problems with the window washers? I use Einszett Anti-frost Washer Fluid. I found my washers sometimes don't work. At first I thought the Einszett Anti-frost Washer Fluid was freezing but sometimes the front works but the back doesn't and vis versa. And yesterday the drivers side stopped working and the passenger side was barely working.

Any insight? Otherwise, I'm just going to take it in to get looked at.

bill_de 01-04-2014 12:59 PM

Re: Window washer problem
 
It could be freezing, not in the tank, but in the lines. The difference might be how the sun is hitting the Jeep.

JohnS 01-04-2014 05:35 PM

Re: Window washer problem
 
My passenger side windshield washer stopped working last week. Turned out the plastic elbow on the nozzle, that the line attaches to, broke off and the fluid was squirting into the engine compartment. I had to get the nozzle assembly replaced.

SRTBLK 01-04-2014 06:50 PM

Re: Window washer problem
 
Had the same problem several weeks ago, first began as decreased power of fluid then no fluid came out and noticed some fluid coming out of hood vents while driving. Nothing was broken but place where tubing attaches to nozzle was loose. So I used some electrical tape to secure it so it would never happen again.

salsfirst 01-05-2014 02:45 PM

Thanks guys, I'll take a look.

CheapshotLou 01-05-2014 06:50 PM

Re: Window washer problem
 
I own a 12 WK2.

My fronts were barely working a few weeks ago and now nothing comes out. I can hear the pump working. Rear works perfect. Not in the mood to take it to the dealer.

SRTBLK 01-05-2014 08:15 PM

Re: Window washer problem
 
Quote:

Originally Posted by CheapshotLou (Post 955151)
I own a 12 WK2.

My fronts were barely working a few weeks ago and now nothing comes out. I can hear the pump working. Rear works perfect. Not in the mood to take it to the dealer.

pop the hood, if it was what happened to me, easy fix in two minutes.

RAC88 01-06-2014 12:18 AM

Same thing happened to me. Perhaps a recall of the assembly on the horizon???


All times are GMT -5. The time now is 01:29 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community