Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Windshield Washer Fluid fluid light won't go out. (http://www.jeepgarage.org/f107/windshield-washer-fluid-fluid-light-wont-go-out-70156.html)

driver354 01-08-2014 05:00 PM

Windshield Washer Fluid fluid light won't go out.
 
Had the washers stop working the other day at the tail end of a snowstorm and very cold(5 degrees during the day) weather. I didn't know if the lines froze, the nozzle, etc. I stopped and filled up the reservoir that appeared empty(although no light came on) with -25 Rain-X fluid and everything started working fine again. Next day, the washer fluid light comes on. Now whenever I start the car, the light is out, and about 3 minutes after running the light comes back on even though the reservoir is topped off to within 3 inches of the cap. I'm thinking it might be the sensor, however I have no idea where to look for said sensor to make sure that it's plugged in. I got alot of hard packed slush up in the wheel wells on my snowy drive so it could have knocked the sensor wire off, or damaged the sensor. Anyone else experienced this or have a schematic of the washer fluid reservoir, sensor, and pumps?


Thanks

ETA--The front and rear washers both work fine.

jamesdomagalski 01-18-2014 02:33 AM

Re: Windshield Washer Fluid fluid light won't go out.
 
I was wondering the same thing. I filled the reservoir the other day and now the light continually comes on. It's been cold here lately, but it was warmer when I filled the tank. The wipers and fluid dispenser is working fine.

11Hemi 01-21-2014 09:45 PM

Re: Windshield Washer Fluid fluid light won't go out.
 
Quote:

Originally Posted by driver354 (Post 956763)
Had the washers stop working the other day at the tail end of a snowstorm and very cold(5 degrees during the day) weather. I didn't know if the lines froze, the nozzle, etc. I stopped and filled up the reservoir that appeared empty(although no light came on) with -25 Rain-X fluid and everything started working fine again. Next day, the washer fluid light comes on. Now whenever I start the car, the light is out, and about 3 minutes after running the light comes back on even though the reservoir is topped off to within 3 inches of the cap. I'm thinking it might be the sensor, however I have no idea where to look for said sensor to make sure that it's plugged in. I got alot of hard packed slush up in the wheel wells on my snowy drive so it could have knocked the sensor wire off, or damaged the sensor. Anyone else experienced this or have a schematic of the washer fluid reservoir, sensor, and pumps?



Thanks

ETA--The front and rear washers both work fine.

I had the same issue. My solution was putting the washer fluid in the washer fluid tank and not the coolant overflow ;)

You only make that mistake once!

StaticFX 01-21-2014 10:16 PM

Re: Windshield Washer Fluid fluid light won't go out.
 
Bahahahahahahahahaha

ekbGC2013 01-24-2014 09:45 AM

Re: Windshield Washer Fluid fluid light won't go out.
 
I am having the same issue; the tank is full of winter washer fluid and my light won't go off...it's 11F here so not sure if that has anything to do with it...

Rallyrcr87 01-27-2014 01:20 PM

Re: Windshield Washer Fluid fluid light won't go out.
 
Same issue here. Light came on when tank ran out as it is supposed to but than never turned off been over a week now

mazster43 02-04-2014 09:13 AM

Mine is now doing this as well. Friday the low washer fluid light came on. Put a gallon in and filled it almost to the top. Saturday there was no light. Last night the low washer fluid light came on again and on this morning too.

AAAA 02-04-2014 11:53 AM

Re: Windshield Washer Fluid fluid light won't go out.
 
mazster43- Excellent avatar. My thoughts exactly.

jgc4ever 02-04-2014 10:26 PM

Re: Windshield Washer Fluid fluid light won't go out.
 
I didn't know there was a light for this. cool

hops23 02-13-2014 03:07 PM

Re: Windshield Washer Fluid fluid light won't go out.
 
Mine has done this the last 3 morning drives into work. The first 2 were -0 and the 3rd was in the teens. The light comes on after about 30 minutes of driving. when i leave work, no light. The reservoir is fairly full.

mazster43 02-13-2014 05:49 PM

An interesting update on the idiot light. today was a regular heat wave adding here, made it up to 25. The low fluid has gone out and stayed off. Was 8 this morning and the light was on. Hopefully it stays off but I don't like that it seems to be cold weather related.

mazster43 02-15-2014 11:40 AM

12 degrees this morning and the low fluid light is back on. It isn't supposed to go over 20 until next week. Will be interesting to see if the light goes out in the warmer weather.


All times are GMT -5. The time now is 06:20 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community