Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   p0740 (http://www.jeepgarage.org/f203/p0740-70305.html)

hoffmanestates 01-12-2014 06:17 PM

p0740
 
I been reading into this code anything from tps to trans replacement, anyone come across this recently.

02 4.7

Sent from my LG-P999 using Tapatalk 2

fnkychkn 01-12-2014 06:43 PM

Re: p0740
 
from online database:

Case Number: K18805380
Vehicle Issue: Customer may complain of the MIL lamp illumination. Upon analysis, it is determined the MIL is caused by DTC P0740.;Follow diagnostic test procedure as recommended in the service manual. Review recommendations if there are no possible causes remaining.
System or Component: Customer Concern (No DTCs)
Recommendation: Remove the pump and converter, and check for sticking TCC switch or T/C regulator valves in the pump. [Check the valves by removing the retainer and spring, and checking whether the valve will slide freely back and forth under its own weight as the valve body is tipped back and forth] If valves are stuck, clean them. If they're still sticky, replace the pump assembly. If pump is OK, then replace converter. Also, if there is any significant debris in the pump (like coffee grounds in the cooler bypass circuit), then the converter and transmission cooler should be replaced.

have seen these valves stick on a few RFE transmissions.

hoffmanestates 01-12-2014 07:12 PM

so now I must locate a solenoid pack and replace it

Sent from my LG-P999 using Tapatalk 2

fnkychkn 01-12-2014 07:16 PM

Re: p0740
 
no solenoid pack. need to remove transmission. remove and disassemble pump.

Frango100 01-12-2014 07:20 PM

Re: p0740
 
To set this P0740 DTC, the TCM is monitoring the engine speed and compares it to the transmission input speed. If a certain difference is monitored over a certain time, the code will be set.
A faulty input speed sensor could already cause this problem. Just swap the input speed sensor with the output speed sensor and errase the DTC. Testdrive to see if it made any difference. if the input speed sensor is faulty, it could give some harsh shifting now as well.
The valves mentioned by fnkychkn could be the problem, but you will have to remove the transmission to get access to that, so would be a last option on my list.
Also a problem with the L/R-TCC solenoid (part of the solenoid block) or a worn torque converter clutch could be the problem.

hoffmanestates 01-12-2014 07:23 PM

which is why I want to replace the solenoid pack as the tcc is also combined I believe
I have always had a harsh initial grab from park to D. like that clunk noise but only intermittent hot/freezing don't matter. I cleared the code and ill drive tomorrow. it has 0 connection but I replaced my burnt out tail light bulb and this dtc popped on shortly after.

frango if u know of a part # or name of the solenoid pack let me know so I can start sourcing one.

Frango100 01-13-2014 03:10 AM

Re: p0740
 
The solenoid for the TCC is combined with the L/R. Which one it uses depends on the position of the solenoid switch valve in the valve body. So a bad working L/R-TCC solenoid probably also gives a slipping 1st gear.
Did you swap the speed sensors to start with?
New OEM solenoid you can get for a good price at www.electricaladvantage.net, they sell also speed sensors and other electrical tranny stuff, but i also got my both filters from them.

hoffmanestates 01-13-2014 06:24 AM

no I haven't swapped sensors yet as I don't have access to a lift and we have ice/snow/ freezing temps, good ol Chicago. once it warms up I will swap sensors and take it for a spin.

Sent from my LG-P999 using Tapatalk 2

hoffmanestates 01-13-2014 06:37 AM

I found the solenoid block update $300. not bad. with this jeep I have learned that what ever breaks on it I go to replace it and it's been replaced already, like my blend doors stopped working, purchased the metal door update, already has them installed purchased a stepper motor still doesn't work. I been trying to replace the Cams with h.o Cams when I was rebuilding the heads machine shop told me it already has h.o CAms installed. this truck has been throwing me off a lot lately.

Sent from my LG-P999 using Tapatalk 2

hoffmanestates 01-13-2014 07:33 AM

so after drive to work, it ran 65 at 1,9-2k when od button was pressed it dropped a gear and pressed again and went to od and rpm go down. maybe just a fluke

Sent from my LG-P999 using Tapatalk 2

hoffmanestates 01-13-2014 05:28 PM

so problem came back

Sent from my LG-P999 using Tapatalk 2

Frango100 01-14-2014 02:22 AM

Re: p0740
 
01Grand had this same DTC set and for him the solution was a new torque converter. Read here: http://www.jeepgarage.org/f51/transm...les-66079.html


All times are GMT -5. The time now is 05:01 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community