Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Acceleration Delay (http://www.jeepgarage.org/f77/acceleration-delay-70397.html)

GC10LTD 01-14-2014 05:02 PM

Acceleration Delay
 
Maybe Im crazy but ever since I got my jeep, I've noticed that when I push on the gas pedal, it lags sometimes when the RPM's go up. For example, if I make a turn at a stoplight and need to accelerate quickly, I can give it gas, but it takes a second to start accelerating. Anybody know what my issue may be here? I feel like I have to hammer the gas pedal to get her to get going. Any mods that can fix this so I have better throttle response? I have a K&N 77 series and didn't notice much difference.

tomk 01-14-2014 05:51 PM

Re: Acceleration Delay
 
My '07 does this a lot, the '14 less.

Accelerating after a 'rolling stop' seems to be the worst situation.

...tom

GC10LTD 01-14-2014 06:03 PM

Quote:

Originally Posted by tomk (Post 959831)
My '07 does this a lot, the '14 less. Accelerating after a 'rolling stop' seems to be the worst situation. ...tom

Is there any way to change this? Or make it more responsive?

jerryjjansen 01-14-2014 08:03 PM

My 14 GC Limited V8 did this when I first bought it. Installed a K&N CAI and it went away to never return.

GC10LTD 01-14-2014 08:52 PM

Re: Acceleration Delay
 
Quote:

Originally Posted by jerryjjansen (Post 959888)
My 14 GC Limited V8 did this when I first bought it. Installed a K&N CAI and it went away to never return.

I installed a K&N intake system (77 series) and it still does it. I don't notice any change over the stock intake.

GC10LTD 01-15-2014 08:02 AM

Quote:

Originally Posted by tomk (Post 959831)
My '07 does this a lot, the '14 less. Accelerating after a 'rolling stop' seems to be the worst situation. ...tom

Yes! The rolling stop is by far the worst. It really bugs me. I really want to fix it

siegs7 01-15-2014 09:00 AM

Re: Acceleration Delay
 
Quote:

Originally Posted by GC10LTD (Post 960122)
Yes! The rolling stop is by far the worst. It really bugs me. I really want to fix it

I agree. I have the same problem. I seem to notice it more from a stop to go, or when turning a corner - very annoying. It does seem to be more responsive if I drive in Sport mode though.

A fix/patch/flash etc... would be great!


All times are GMT -5. The time now is 12:54 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community