Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   2014 JGC Uconnect 13.48.3 + iPhone 7.0.4 = no Bluetooth pairing (http://www.jeepgarage.org/f107/2014-jgc-uconnect-13-48-3-iphone-7-0-4-no-bluetooth-pairing-71353.html)

Wino 02-06-2014 03:15 PM

2014 JGC Uconnect 13.48.3 + iPhone 7.0.4 = no Bluetooth pairing
 
Just got my 2014 JGC back from dealer due to the N58 safety recall. They updated software for both transmission TCM and Uconnect up to 13.48.3.

I can no longer get EITHER my wife's iPhone 5 or my iPhone 5c to pair with Uconnect via Bluetooth. Both phones are up to date with iOS 7.0.4.

I put the Uconnect screen into phone mode, settings, add phone. Then I turn on my phone's bluetooth and select Uconnect under devices. Same thing every time:

On iPhone - "Pairing Uncuccessful" Make sure "Uconnect" is turned on, in range, and is ready to pair.

I've also tried turning the phone's bluetooth on and off during the pairing, and tried to do the pairing in reverse order (disable then enable iPhone bluetooth.... THEN put the Uconnect screen into pairing mode). No dice.

I called Uconnect service and, to put it mildly, they were less than helpful.

Anyone had this problem and found a solution? I'd rather not roll back my iPhone to an older (less secure) software version.

lectricman 02-06-2014 04:49 PM

Re: 2014 JGC Uconnect 13.48.3 + iPhone 7.0.4 = no Bluetooth pairing
 
Quote:

Originally Posted by Wino (Post 971513)
Just got my 2014 JGC back from dealer due to the N58 safety recall. They updated software for both transmission TCM and Uconnect up to 13.48.3.

I can no longer get EITHER my wife's iPhone 5 or my iPhone 5c to pair with Uconnect via Bluetooth. Both phones are up to date with iOS 7.0.4.

I put the Uconnect screen into phone mode, settings, add phone. Then I turn on my phone's bluetooth and select Uconnect under devices. Same thing every time:

On iPhone - "Pairing Uncuccessful" Make sure "Uconnect" is turned on, in range, and is ready to pair.

I've also tried turning the phone's bluetooth on and off during the pairing, and tried to do the pairing in reverse order (disable then enable iPhone bluetooth.... THEN put the Uconnect screen into pairing mode). No dice.

I called Uconnect service and, to put it mildly, they were less than helpful.

Anyone had this problem and found a solution? I'd rather not roll back my iPhone to an older (less secure) software version.

I don't have an I-phone but I happen to be reading the manual today and remember it saying that the Apple needed to be paired with a USB cord. I don't know if that is to actually pair it or that it's the only way to use an I-phone in the car. The dealer told me that U-connect is made for Android. Don't know how true that is though.

nikon858 02-07-2014 02:30 PM

Re: 2014 JGC Uconnect 13.48.3 + iPhone 7.0.4 = no Bluetooth pairing
 
Works fine on my iPhone with 7.0.4 bring it back to the dealer and make them figure it out since it worked before you brought it in.

Otis10 02-07-2014 11:17 PM

Same thing happened to me.. Bluetooth audio stopped working for me after the software update.. Another annoying glitch with this SUV.. My text messaging doesnt work either with the Uconnect. Dont they know most people have freaking IPhones!

siegs7 02-08-2014 09:25 AM

I would try holding down power and home buttons to rest your iPhone. I had this happen once, but after I rest the iPhone, I didn't have that problem. It's worth a try, and easier/faster than reloading the Uconnect software.


All times are GMT -5. The time now is 11:50 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community