Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   2007 Grand Cherokee electrical issue? (http://www.jeepgarage.org/f181/2007-grand-cherokee-electrical-issue-71816.html)

bobtpot 02-17-2014 11:44 AM

2007 Grand Cherokee electrical issue?
 
While driving, my REC radio started cutting out. The display works fine but CD, NAV and radio all have no volume. After restarting the vehicle I was still having the same radio issue but now my tach was acting up. While at idle, it would keep dropping from 1200 to 0 and then go back up again. The engine was running fine, just the tach acting up. I just had the ignition module replaced two weeks ago because of a problem with the SDO. It would randomly start flashing all of the lights and the gauges would go crazy. It was fine for a few weeks but now this started happening. I don't know if they are related or if I have a different issue. If anyone has heard of this or knows what it might be please get back to me.

Thank you!

Bizitz 02-19-2014 07:15 PM

Re: 2007 Grand Cherokee electrical issue?
 
Quote:

Originally Posted by bobtpot (Post 977388)
While driving, my REC radio started cutting out. The display works fine but CD, NAV and radio all have no volume. After restarting the vehicle I was still having the same radio issue but now my tach was acting up. While at idle, it would keep dropping from 1200 to 0 and then go back up again. The engine was running fine, just the tach acting up. I just had the ignition module replaced two weeks ago because of a problem with the SDO. It would randomly start flashing all of the lights and the gauges would go crazy. It was fine for a few weeks but now this started happening. I don't know if they are related or if I have a different issue. If anyone has heard of this or knows what it might be please get back to me.

Thank you!

Mine (2007 JCG 5.7) just started the same thing tonight. I thought I saw it do it once a few weeks back.. but it never did it again. Tonight it did it again... and kept doing it.

Ideas anyone?

Bizitz 02-19-2014 08:11 PM

Re: 2007 Grand Cherokee electrical issue?
 
Seems after doing some research on here, it seems the MultiFunction Light switch (Left of the steering wheel) is causing the problem. It looses connections, i am guessing internally, and causes problems.

Can someone confirm this?

Now, here is excatly what mine does:

Starts up, all fine.

Then, Exterior/Interior lights begin flashing on and off, all the warning lights come on and off as well. everything else seems to work fine, engine runs fine.

-------------------------------------------------------------------

Ok,

After a little more research.. it seems while at it... I need to replace the Multifunction Stalk, Ignition switch and battery.

Any other suggestions?

2005JGC 02-20-2014 10:57 PM

Re: 2007 Grand Cherokee electrical issue?
 
I don't know what was meant by "ignition module" as Chrysler doesn't use an ignition module. They do use an ignition switch!

That said, the junction block has come common issues. there are internal, non replaceable relays that fail over time. Next time it is doing it get something hard, pull down the silencer under the steering wheel and give it a couple love taps and see if the symptom changes at all. I don't have access to wiring diagrams at home so this may or may not be a decent suggestion. If the amp is fed by one of these ignition run/start relays, it would explain why the radio, likely fed by another power source is powering up but the amp is not, so no sound.


All times are GMT -5. The time now is 08:12 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community