Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   help me out with a few problems? (http://www.jeepgarage.org/f203/help-me-out-with-a-few-problems-72360.html)

Rgjr702 03-03-2014 05:54 AM

help me out with a few problems?
 
Have a tick when driving slow might be the u joints but has progressively gotton worse but still only when going slow. I do have tires that are bigger than stock without a lift?
Also have a ticking noise coming from the engine only sometimes not always. Maybe an exhaust leak?
And finally when ever I'm cold starting the truck and drive the rpms go up high before switching to second and when it does it jerks. Then after that it's fine. Occasionally it will jerk when driving slow from complete stop like a stop sign? Any ideas?

2000 4.7 grand Cherokee limited
All time 4wd quadra trac ii I think.
120k miles and engine feels strong
So I hope ticking isn't a cracked head or something.

bill_de 03-03-2014 06:41 AM

Re: help me out with a few problems?
 
Could the first one be a stone or something stuck in a tire tread?


---

Frango100 03-03-2014 07:11 AM

Re: help me out with a few problems?
 
Did you already have a look underneath the jeep to check both drive shaft CV joint boots and the propeller shaft joints (CV or U joint)?
Ticking noise from the engine could be hydraulic lash adjuster? There is a ticking coming from the EVAP purge solenoid in the engine bay on the left fender (looking from drivers position). This will only happen when the engine is warmed up (at least not in the first few minutes after cold start)
Regarding the transmission, is regular maintenance done in time (fluid and filters change)? Could eventually be a problem with the TPS or one of the speed sensors. It will not hurt at least to check/clean the connectors from TPS and speed sensors to start with.

Rgjr702 03-07-2014 02:09 PM

Re: help me out with a few problems?
 
I got an update on the ticking noise while driving, here is a video of where it is comming from, any ideas?

2000 JEEP WJ GRAND CHEROKEE TICKING SLOW DRIVING - YouTube

just in case it is not obvious, its the driver side twords the middle of the truck.

Rgjr702 03-07-2014 04:59 PM

Re: help me out with a few problems?
 
Quote:

Originally Posted by Frango100 (Post 985316)
Did you already have a look underneath the jeep to check both drive shaft CV joint boots and the propeller shaft joints (CV or U joint)?
Ticking noise from the engine could be hydraulic lash adjuster? There is a ticking coming from the EVAP purge solenoid in the engine bay on the left fender (looking from drivers position). This will only happen when the engine is warmed up (at least not in the first few minutes after cold start)
Regarding the transmission, is regular maintenance done in time (fluid and filters change)? Could eventually be a problem with the TPS or one of the speed sensors. It will not hurt at least to check/clean the connectors from TPS and speed sensors to start with.


any ideas to the video i posted?

Frango100 03-07-2014 10:10 PM

Re: help me out with a few problems?
 
Sounds as the drive chain inside the T-case with too much slack. Will need a new chain or swap T-case.

Rgjr702 03-08-2014 03:42 AM

Re: help me out with a few problems?
 
What's the best option money wise? I have a mechanic that doesn't charge much (my cousin) and he has swapped transmissions and such many times. So that's not a problem but as for the trouble.and parts wise. What's the cheapest? Used tcase or chain swap

Frango100 03-08-2014 07:26 AM

Re: help me out with a few problems?
 
You didnīt mention which four wheel drive system you have. Looking at the video it seems to have the 4.7L with 5-45RFE transmission, which i believe only comes with Quadra Trac II or Quadra Drive. Both use the same T-case, the NV247. Besides the chain can stretch too much and touch the housing bottom (there is no tensioner in there and when getting stretched too much it will rub on the housing and wear the aluminum away), it also has a progressive coupler which transfers part of the torque to the front wheels when a speed difference between front and rear prop shafts occurs. This coupler in many cases is shot, preventing the 4all time to work. In that case only 4lo works. For this four wheel drive system its very important that front and rear wheels wear evenly, because a diameter difference between front and rear wheels will cause a rotational speed difference between the front and rear prop shafts and will cause the progressive coupler to be activated all the time and wear the clutch away rapidly.
So if you want to stay with this type of T-case, its probably better to get a good used one. What many other did is swapping in a NV242 T-case. Here you can choose between full time 2 wheel or four wheel drive. This swap also requires a new rear prop shaft and T-case shift lever.
Getting a used T-case is still no guarantee on the state of the chain and/or progressive coupler.
So if your T-case works ok, then maybe a new chain would be the cheapest option.

Rgjr702 03-11-2014 11:44 PM

Re: help me out with a few problems?
 
Okay. Fixed everything except the t case. So then I'll probably have someone swap the chain for me because t case works fine. I think the big tires might have put too much stress on the driveshaft causing the case to get messed up.

As for the ticking noise I just did what this guy did in this video and used synthetic oil. No more ticking from the engine and did a tune up and swapped all the coils. Runs beautiful now.

And btw thanks so much frango you helped me locate these problems I'll update this thread as soon as I fix the t case prob in case anyone else has this problem in the future

https://www.youtube.com/watch?v=pgYs...e_gdata_player

Frango100 03-12-2014 07:56 AM

Re: help me out with a few problems?
 
What did you do to solve the problem with the transmission?

Rgjr702 03-13-2014 05:36 AM

Re: help me out with a few problems?
 
Haven't tried much with that since it comes and goes when it wants to. It's only does it one time when I cold start and drive n the trans shifts.after that nothing. Only on rare occasions will it do it after that

Frango100 03-13-2014 06:41 AM

Re: help me out with a few problems?
 
Most of the times shifting problems are caused by a bad TPS or speed sensor. Keep track on the fluid changes and you will be ok.


All times are GMT -5. The time now is 02:42 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community