Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Wk2 SRT electrical issues (http://www.jeepgarage.org/f77/wk2-srt-electrical-issues-72900.html)

dpaps 03-16-2014 11:26 PM

Wk2 SRT electrical issues
 
Well the big fella is having a bad day:
- not recognising key fobs
- tyre pressure service lighting up (no flats so this is wrong)
- alarm goes off until you restart it
- Central locking or unlocking not working
- starts then loses key fob and beeps relentlessly
- after stop won't start again

Had roadside assist see it. Did a battery reset and no fix. Into dealer tomorrow. Done 5000kms.

Hopefully it gets fixed and it's something small.
Thanks

Red Suns 03-17-2014 12:57 AM

That is quite a healthy list of problems. Did all these problems came to light all in the same day?

dpaps 03-17-2014 01:41 AM

Quote:

Originally Posted by Red Suns (Post 992813)
That is quite a healthy list of problems. Did all these problems came to light all in the same day?

Yeah all in one go. Should all be related. So whatever the issue is should have cause all those problems.
Not happy though, brand new car :(

Kashef 03-17-2014 02:22 AM

Re: Wk2 SRT electrical issues
 
Loose ground maybe?

dpaps 03-17-2014 02:37 AM

Quote:

Originally Posted by Kashef (Post 992839)
Loose ground maybe?

Not sure what you mean? Do you mean bad earth?

Red Suns 03-17-2014 08:11 AM

http://www.wk2jeeps.com/tsb/rc_N5813.pdf

Whether this applies to you or not, a loose ground in a vehicle's 12V electrical system can cause weird behavior such as yours. That's probably where I would start.

Have you done anything recently like drive through a large pool of standing water, went off-roading, updated your uconnect firmware, or etc. just before you got this cluster of problems?

dpaps 03-17-2014 04:19 PM

Quote:

Originally Posted by Red Suns (Post 992935)
http://www.wk2jeeps.com/tsb/rc_N5813.pdf Whether this applies to you or not, a loose ground in a vehicle's 12V electrical system can cause weird behavior such as yours. That's probably where I would start. Have you done anything recently like drive through a large pool of standing water, went off-roading, updated your uconnect firmware, or etc. just before you got this cluster of problems?

Nah nothing at all. It's summer here too so no random pools of water to drive through.
Hopefully dealer will fix quickly today

Red Suns 03-17-2014 07:15 PM

Re: Wk2 SRT electrical issues
 
Best of luck, hope you get this squared away in a quick and painless fashion.


All times are GMT -5. The time now is 01:17 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community