Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Yet another problem...... (http://www.jeepgarage.org/f107/yet-another-problem-73265.html)

pensfan414 03-26-2014 07:04 AM

Yet another problem......
 
Started up the 14 GC this morning only to find that all my interior background lighting as well as my headlights were non-functional. I didn't have time to look into it further. My only thought is a fuse blown but anyone else have an idea of what this could be or experienced a similar issue? Thanks.

Briant73 03-27-2014 11:31 AM

Re: Yet another problem......
 
With the car off check the fuses, it could possibly be a fuse that needs pushed back in, a few owners have found there fuses have unseated themselves or were never seated fully.

StaticFX 03-28-2014 08:42 AM

Re: Yet another problem......
 
first.. try again before checking fuse.About 10 times now I have had to wait for them. Open the door.. dark.. get in.. dark.. close door.. dark.................... ding there they go.
Why on earth they are computerized I will never understand but... they are.

yet another random system screw up. I swear the person who designed this thing was a few fries short of a happy meal.

Evolv0 03-28-2014 09:53 AM

Re: Yet another problem......
 
Quote:

Originally Posted by StaticFX (Post 999488)
yet another random system screw up. I swear the person who designed this thing was a few fries short of a happy meal.

LOL ..

But yes I would also double check every single fuse in and out of the car, then try again.


All times are GMT -5. The time now is 11:33 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community