Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   2011+ Dodge Durango-WD (http://www.jeepgarage.org/f177/)
-   -   Transmission problem... (http://www.jeepgarage.org/f177/transmission-problem-73688.html)

Tvo-2 04-04-2014 08:02 PM

Transmission problem...
 
So my wife was driving her 2014 V6 awd Durango today when all of a sudden the engine started to rev but the vehicle started to slow down as if the truck was put in neutral. My wife freaked out so she didn't notice what gear was displayed on the dash but she managed to pull to the side of the road. She made sure that the shift selector itself was in fact still in 'D' and it was. She put the truck in park and then back in drive and it worked fine. She is totally convinced that she did NOT hit the manual paddle shifters accidentally (at first I thought she may have managed to drop all the way down to 1st gear unknowingly and revved the heck out of the engine). I did a quick search on the forum but didn't see anything and I was wondering if anyone had any kind of similiar experience or could offer a possible explanation...thanks in advance for any insight

mcfarl58 04-05-2014 08:19 AM

Sounds an awful lot like she downshifted manually.

davewg 04-07-2014 08:45 AM

Re: Transmission problem...
 
+1

My wife's hit the paddle at least once by accident and experienced something similar.


All times are GMT -5. The time now is 10:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community