Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Current GC owner with Electronic issues (http://www.jeepgarage.org/f181/current-gc-owner-with-electronic-issues-74087.html)

pappi352 04-16-2014 11:10 AM

Current GC owner with Electronic issues
 
Hey guy's, I am in need of help. First time ever posting. I have an ABS/Traction control issue. 005 Jeep Grand Cherokee 5.7 Hemi. Changed both front wheel sensors and rewired broken conection on drivers side. Yes I triple checked to make sure I had correct wire to each pin. Ordered Brake Light Switch and plan on putting that in today. Lights still on and front wheel grabs for a split seond when going forward till audible chime goes of then truck rolls freely. ANY IDEAS PLEASE, this is killing me.
Thanks

lstowell 04-16-2014 03:17 PM

Re: Current GC owner with Electronic issues
 
Quote:

Originally Posted by pappi352 (Post 1008367)
Hey guy's, I am in need of help. First time ever posting. I have an ABS/Traction control issue. 005 Jeep Grand Cherokee 5.7 Hemi. Changed both front wheel sensors and rewired broken conection on drivers side. Yes I triple checked to make sure I had correct wire to each pin. Ordered Brake Light Switch and plan on putting that in today. Lights still on and front wheel grabs for a split seond when going forward till audible chime goes of then truck rolls freely. ANY IDEAS PLEASE, this is killing me.
Thanks

Offhand, this sounds more like a controller issue...
However, does the 05 still have the problem with crud/corrosion on an ABS connector on the passenger front fender as it passes out of the engine compartment?
[don't have an FSM]
The older ZJ used to get crud in there from having fun in creeks, snow, and mud, and the fix was to carefully remove the connector and clean both sides with something that is NOT a rubber eraser [sulfur just recruds if you don't get it all off] and then reseat it.

Got a scan tool that can pull fault codes?
Three on/off/on cycle pull anything?

pappi352 04-16-2014 03:37 PM

Re: Current GC owner with Electronic issues
 
hey thaks for the reply. yup pulled 3 codes c100a driverside sensor c1015 pass sensor & just saw p0571 which was the brake light switch. Changed that today going to hit Advanced and use there reader and see if it clears this up. Didnt notice the connector you were talking about my abs mod is on drivers side behind battery

lstowell 04-16-2014 05:29 PM

Re: Current GC owner with Electronic issues
 
The connector I mentioned is one that goes thru the fender near the front passenger side. Yours is a newer vehicle than the ZJ and might not have one, since those were infamous for crudding up while having fun.

The tone rings need to come thru to the ABS controller from somewhere...
C100A is the left wheel speed sensor, which is not the same as C1014 which would be the abs sensor. I'd suggest checking that out first... but unfortunately I don't have a good diagram, so hopefully someone with one or has troubleshot your year will chime in.

Gus9890 04-17-2014 10:53 AM

Re: Current GC owner with Electronic issues
 
Welcome to the JG!!

pappi352 04-17-2014 11:12 AM

Re: Current GC owner with Electronic issues
 
ok thank you for all your hlp will keep digging, eventually i will find it before the cost hits $2000.


All times are GMT -5. The time now is 11:30 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community