Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WJ (http://www.jeepgarage.org/f51/)
-   -   Uk newbie needs help 4.7 V8 HO head gasket? (http://www.jeepgarage.org/f51/uk-newbie-needs-help-4-7-v8-ho-head-gasket-74461.html)

carswaps 04-27-2014 02:15 PM

Uk newbie needs help 4.7 V8 HO head gasket?
 
I've just bought a Jeep Grand Cherokee V8 4.7 High output with a bad misfire/running problem.

Just to give you a bit of background on the car........
The guy I bought it from had only owned it a couple of weeks and had no technical knowledge at all.
He told me that he had driven it back 200 miles with no problems, no over heating etc but the next day he went to collect his son from school, switched the Jeep off, started fine again, set off and the Jeep cut out at the bottom of a hill.
He tried to start it and it just spun over to the point where he said it felt 'tight' (We'll come back to this in a bit).
He went back to it the next day and it fired straight up but ran with a misfire.....he drove it back home and parked it up.
He had a word with a local garage who told him 'Probably head gasket mate' so he decided to chuck a full bottle of 'K Seal' into the radiator expecting this miracle cure to fix the Jeep.

I went to have a look and took my code reader with me.....Pulled 4 x codes.
P0320 No Crank Reference Signal at PCM.
P0725 Engine Speed Input Circuit.
P1299 Vacuum Leak Found (IAC Fully Seated). (this turned out to be a split pipe)
P1391 Intermittent Loss of Cam position sensor or Crank position sensor

Started the Jeep and it would run and didn't over heat but was missing on at least 2 cylinders (turned out to be 3)
Took it for a very short run as it broke down within a mile (just cut out and would't start again - smelt very warm?)
Managed to start it again by spinning it over and pumping the throttle, managed to drive a little further and same again cut out.
As above re started but was getting harder and harder to get it to fire.
On the occasions when it didn't it was chugging out large amounts of smoke/unburnt fuel - smelt very strong, also would turn over then stop, I was sure this was vapour lock (as the owner stated felt tight) but would turn over again within seconds.
Anyway with 2 of the codes pointing towards the 'Crank sensor' I took a punt and bought it!

This is where the fun begins.....
Got the Jeep home and started to diagnose the misfire:
The coolant looked a strange colour and smelled of putty (I'm assuming that this is the K seal).
No apparent water in the oil (no milkiness).

Started the Jeep - misfire.
left bank is cylinder 2, 4, 6, 8 and right bank is 1, 3, 5, 7.
Pulled of connector to cylinder 2 and nothing - no change in engine note.
All others ok except cylinder 5 & 7 (next to each other on R/H/bank) both not firing.
Swapped plugs and the next time cylinder 1, 5 ,7 were not firing (each plug that went into 1, 5, 7 had already fired properly so this rules out the plugs) still 5 and 7 not firing each time.
Each plug has its own coil pack, swapped all these around with no change.
Next as the codes were pointing to crank sensor I bought a new one of those, fitted (worst job I have ever done as the old one snapped off in the block) eventually fitted but still the same misfire problem.
On to the sniff test......
Sniff test kit in the radiator and nothing just stayed blue (at this point I had topped the radiator up and may have put a bit too much in)removed some coolant and re-tested and this time as soon as I started the Jeep the test tube filled with coolant turning the blue liquid a Green/yellow.
That's it I thought, definitely head gasket as its pressurising the coolant and its turned green/yellow.

On to stripping the engine down...........
http://i66.photobucket.com/albums/h2...psc06f6369.jpg
The oil stain down the left bank is where I spilled oil trying to refill after dropping the oil :0)
This is where I started to doubt myself,
All the spark plugs looked ok,
http://i66.photobucket.com/albums/h2...psefffb936.jpg
http://i66.photobucket.com/albums/h2...ps25bf32a7.jpg
http://i66.photobucket.com/albums/h2...ps04eade09.jpg
http://i66.photobucket.com/albums/h2...ps289d78a9.jpg
http://i66.photobucket.com/albums/h2...psa76289ca.jpg
http://i66.photobucket.com/albums/h2...ps3b2ce676.jpg
http://i66.photobucket.com/albums/h2...pseeb7dcb9.jpg
http://i66.photobucket.com/albums/h2...ps645a8cf5.jpg
Took both the rocker covers off and nothing out of the ordinary in there (Some have experienced rockers falling off but was fine).
Timing chains look fine and not slack.
Inlet manifold off and you can see the head gaskets....both look like multi layer steel gaskets? are these original or have the heads been done once?
http://i66.photobucket.com/albums/h2...ps41c1cd70.jpg
http://i66.photobucket.com/albums/h2...ps78c19fa5.jpg
At this point I had a thought, lets drop the coolant and have a good look at it...
This is the colour it was, now I'm not sure what effect the 'K Seal' had on the colour or even what colour 'K Seal' is but it was a bright orange/yellow colour.
http://i66.photobucket.com/albums/h2...psa2c49e42.jpg
http://i66.photobucket.com/albums/h2...ps8bacda6e.jpg
I mixed this with some of the blue sniff test fluid and it turned it green!
Was it the head gasket after all?
http://i66.photobucket.com/albums/h2...ps23953082.jpg
http://i66.photobucket.com/albums/h2...ps245c8303.jpg
So far the only thing that pointed to head gasket was the coolant coming out of the radiator showing some sort of pressurising but the car had run for 10 - 15 mins before the sniff test so could this be normal?

The last thing I have done is a compression test:
The results were.
Cylinder 1: 190 - 200psi
Cylinder 2: 190 - 200psi
Cylinder 3: 190 - 200psi
Cylinder 4: 190 - 200psi
Cylinder 5: 190 - 200psi
Cylinder 6: 190 - 200psi
Cylinder 7: 190 - 200psi
Cylinder 8: 190 - 200psi
Am I barking up the wrong tree with the original head gasket diagnosis?

Frango100 04-28-2014 05:16 AM

Re: Uk newbie needs help 4.7 V8 HO head gasket?
 
Welcome to the garage.
Did you also do a leakdown test to see if that also passes?
Did you use an original mopar crank sensor, since this engine seems to be a bit picky on aftermarket ones? Did you check the wiring to the crank sensor (visually and ohms)? Did the fault code for the crank sensor disappear after the sensor change?
Could eventually be a problem with the PCM itself. Sometimes the housing gets corroded and swells, making shorts inside. Also check/clean all the PCM connectors.

carswaps 04-28-2014 05:28 AM

Re: Uk newbie needs help 4.7 V8 HO head gasket?
 
Quote:

Originally Posted by Frango100 (Post 1013327)
Welcome to the garage.
Did you also do a leakdown test to see if that also passes?
Did you use an original mopar crank sensor, since this engine seems to be a bit picky on aftermarket ones? Did you check the wiring to the crank sensor (visually and ohms)? Did the fault code for the crank sensor disappear after the sensor change?
Could eventually be a problem with the PCM itself. Sometimes the housing gets corroded and swells, making shorts inside. Also check/clean all the PCM connectors.

Thanks Frango100,

I have not done a leak down test yet.
It was an after market crank sensor and yes checked the wiring to it visually and ohms.
Where is the PCM located?

Frango100 04-28-2014 05:54 AM

Re: Uk newbie needs help 4.7 V8 HO head gasket?
 
1 Attachment(s)
The PCM sits on the bulkhead just behind the expansion reservoir. Your jeep being RH driven could be different though.

carswaps 04-28-2014 06:19 AM

Re: Uk newbie needs help 4.7 V8 HO head gasket?
 
Thank you, gives me something to go on.
Time to build it back up.

hoffmanestates 05-01-2014 01:19 PM

Re: Uk newbie needs help 4.7 V8 HO head gasket?
 
Head gasket doesnt have to leak into the cylinder. It can mix with coolant passage, ect.... I did a head gasket as that was my problem. I made a few write ups and pics taken somewhere on this forum


All times are GMT -5. The time now is 04:12 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community