Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Loss in MGP after new plugs (http://www.jeepgarage.org/f5/loss-in-mgp-after-new-plugs-7535.html)

Kaliber35 03-15-2010 02:20 PM

Loss in MGP after new plugs
 
So, this week I did the following maintenance and repairs to my 05 WK:

New NGK Platinum Core Plugs
New front and rear diff oil (Mobile 1)
New transfer case oil
New rear hub assembly
New power steering pump
New rear brakes

Within a few days I have noticed my MPG drop from 16-17 to 13-14. Any idea as to the cause? I suspect the plugs...

maxst2 03-15-2010 07:50 PM

Re: Loss in MGP after new plugs
 
4.7L and 3.7L Should use coppers. Read that many people have issues when they put anything else in there.

JeepKid 03-15-2010 08:46 PM

Re: Loss in MGP after new plugs
 
i noticed the same thing when i changed my plugs. All i did was unplug the negative battery terminal for about 15 minutes because my check engine light came on also and then drove on the freeway for about 2 hours. Once i got back in town the mileage was back to normal . . . I dont know if it was the drive or the battery thing but it worked for me.

SvenskaJeepGuy 03-15-2010 11:24 PM

Re: Loss in MGP after new plugs
 
you used the wrong plugs and that wil cause the MPG to decrease, you have to use copper plugs.

05quadratrac 03-15-2010 11:29 PM

Re: Loss in MGP after new plugs
 
I bought some copper plugs from Autozone, they weren't the Champions from the factory but they were copper core and the guy said they were basically the same thing I think they cost about $1.30 each, I didnt notice any loss in MPG it stayed about the same with maybe a 1mpg increase.


All times are GMT -5. The time now is 12:34 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community