Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   Idle/Stalling problem (http://www.jeepgarage.org/f196/idle-stalling-problem-7711.html)

citizinsoldier11B 03-20-2010 07:08 PM

Idle/Stalling problem
 
Hey Guys!
Just today I started having some problmes with my idle. I have a '00 WJ with the I6 4.0L. with about 167,000 miles. I Went out today and noticed it wasn't idling right when I started up. I got to the top of my street and it almost stalled before I gave it some gas.

At the next light I stopped and it just died. No trouble starting back up but wanted to stall if I lifted up on accelerator.

I have never had this problem and did a little searching around site, looks like it could be acouple of things. I am going to take a better look at it in the AM. I wanted to get some ideas and see if anyone has had similar problem.

Thanks in advance for any tips. :thumbsup:

Chaoul1 03-20-2010 10:56 PM

Re: Idle/Stalling problem
 
I think the problem is with your IAC. Replace that. Also check (Just incase) your Air Filter, Change Fuel Filter, Check your spark plugs to see if they need replacing.

citizinsoldier11B 03-21-2010 06:23 PM

Re: Idle/Stalling problem
 
Thanks, I'll check that out. Went out this morning and checked the air filter, and it is pretty clean. I'm sure I need new spark plugs, i've been putting off a tune-up since the coil pack is $$.

It was idling fine today until it warmed up, then died again.

mountian goat 03-24-2010 11:36 AM

Re: Idle/Stalling problem
 
try replacing your tps sensor, i had the same problem...and i didnt have any engine codes..which was weird

citizinsoldier11B 03-25-2010 09:54 PM

Re: Idle/Stalling problem
 
I looked that up and that sounds a little more like what is happening. I still want to do a full tune up soon. Just need to save some $.

Luckily it stoped staling and just have a a low idle(like around 350-400rpm).

Thanks for the suggestions. This will save me an expensive mechanic trip, even though guy I usually go to is great. I try to save the big things for him!

Quote:

Originally Posted by mountian goat (Post 175472)
try replacing your tps sensor, i had the same problem...and i didnt have any engine codes..which was weird


4jeepers 04-09-2010 09:49 PM

Re: Idle/Stalling problem
 
EGR May not be seating fully due to carbon deposits. Its worth a look before throwing parts at the vehicle and guessing! :slapfight:

Frango100 04-10-2010 01:37 PM

Re: Idle/Stalling problem
 
I had some rough idle problems as well and found the IAC air path almost completely clogged with oil residue. (mine has the 4.7L, but the IAC system is almost identical.) Took the throttle body off for some deep cleaning and after that the problem was solved.

FlyinRyan 04-11-2010 03:56 PM

Re: Idle/Stalling problem
 
I think I may have some 4.0 I6 sensors if you end up needing them.

citizinsoldier11B 04-22-2010 10:05 AM

Re: Idle/Stalling problem
 
Thanks for the tips guys! I put in some new spark plugs and that has helped. Once I get some time to dig into it I'll check everything else out. SInce it's my daily driver not a lot of time to keep it off road. I think it might go into the shop during my three weeks of annual training for the National Guard this summer.


All times are GMT -5. The time now is 06:57 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community