Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Suspension/Brakes/Wheels/Tires (http://www.jeepgarage.org/f185/)
-   -   Click when pressing brakes (http://www.jeepgarage.org/f185/click-when-pressing-brakes-77576.html)

Jeepster13 07-27-2014 06:56 PM

Click when pressing brakes
 
What's up people. I am having a issue and I can't figure out what it is. Every now and then I can a click when pressing the brake pedal. It doesn't happen that often, seems like it happens when cold. I can hear it at the front wheel. I recently changed the brakes and rotors (about 1500 miles ago) I used Wagner thermoquiet pads. Since I was getting this noise now and then I pulled the wheel today and everything seems perfect. I figured it might be the slide pins so I took them out and lubed them up. Took it out for a test and I heard the noise. It's 1 click when I press the pedal down. Any ideas what this is?

Appreciate the help.


Mike


Sent from my iPad using JeepGarage

pwpjeep 08-19-2014 03:17 PM

Re: Click when pressing brakes
 
Hi

Did you discover what the click was? I now have the same on my jeep.

wimbers 08-21-2014 03:31 PM

Re: Click when pressing brakes
 
me too, seems to be coming from the bottom center of the car though, and not the wheel itself.
recently had the entire back rotors and pads renewed.

Rottn35 09-26-2014 11:15 PM

Re: Click when pressing brakes
 
Just replaced front and rear brakes and rotors a week ago, now have the clicking noise too

Jeepster13 09-27-2014 03:57 PM

Re: Click when pressing brakes
 
I still haven't figured out what it is. I tried lubing the caliper pins and that didn't take it away. It doesn't happen often..the only thing I think it could be is the psd moves slightly on the rails since I used ceramic aftermarket vs the mopar.


Sent from my iPad using JeepGarage

Capn37 10-03-2014 07:29 PM

Re: Click when pressing brakes
 
Weird. I just had my rotors and pads (centric rotors and hawk hps pads) and I've noticed a clicking sound also. It seems to happen when applying light to moderate pressure. Anyone figure out what the cause is?


All times are GMT -5. The time now is 01:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community