Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   2005 wk 3.7 Starting issue (http://www.jeepgarage.org/f181/2005-wk-3-7-starting-issue-7780.html)

speakerboy38 03-23-2010 12:57 AM

2005 wk 3.7 Starting issue
 
Hello all! I am new to this forum and it is a great one! My 2005 wk 3.7 with 107k miles won't start within a half hour after driving for more than 10 to 15 mins. Any Suggestions? I also just had a tune up done about a month ago which didn't help. My mechanic said it might be a harness on top of the fuel tank but wants to charge me two hours labor just to check it out. Thanks in advance!

JTK1130 03-23-2010 08:52 AM

Re: 2005 wk 3.7 Starting issue
 
1 - Find a new mechanic..

2 - What happens when you try to start it up?

Chaoul1 03-23-2010 09:31 AM

Re: 2005 wk 3.7 Starting issue
 
Replace the starter. It probably gets too hot to turn the engine over. Get a mechanic to check it out first before doing something.

B.P.O.D 03-23-2010 10:57 AM

Re: 2005 wk 3.7 Starting issue
 
def find a new mechanic

JTK1130 03-23-2010 01:13 PM

Re: 2005 wk 3.7 Starting issue
 
Seriously though, if the problem is with the starter it is very simple to change out. It's about 4 screws to unbolt the splash shield and 2 bolts to undo the starter. You'll just need the socket, extension and a universal... should come right out. Mine went on my 05 a few months back. Was so hot it looked cherry red... If you brought it to a mechanic it should be no more than an hour job as long as you don't have to wait for the new starter to be delivered.

I'm not sure if the problem is with your starter though.. like i asked before.. what happens when you try and start it up?

speakerboy38 03-23-2010 01:30 PM

Re: 2005 wk 3.7 Starting issue
 
I had the started replaced @ 95,000 miles. When I try to start it, it sounds like it wants to start and the engine starts to turn over but it never fully starts

JTK1130 03-23-2010 01:51 PM

Re: 2005 wk 3.7 Starting issue
 
I assume you've already checked the battery and alternator... Jumping the car doesn't help does it?

You need three things to run an engine.... Fuel, Air and Spark... Your original mechanic may be on the right track.. it could have something to do with the fuel pump or the fuel system in general...

Do you have an engine light or have you been able to retrieve any error codes off the trucks computer?

speakerboy38 03-23-2010 02:18 PM

Re: 2005 wk 3.7 Starting issue
 
I checked the alternator and battery connections. They are fine. Jumping doesn't work either. I just got off the phone with my mechanic again and he says he has seen this on another 2005 wk and he said the harness on the top of the fuel tank can become corroded and when replaced it started fine after testing all day. He also said my fuel pump is fine. I don't get a check engine light and I'm not sure if he tried reading codes.

JTK1130 03-23-2010 06:53 PM

Re: 2005 wk 3.7 Starting issue
 
Quote:

Originally Posted by speakerboy38 (Post 174795)
I checked the alternator and battery connections. They are fine. Jumping doesn't work either. I just got off the phone with my mechanic again and he says he has seen this on another 2005 wk and he said the harness on the top of the fuel tank can become corroded and when replaced it started fine after testing all day. He also said my fuel pump is fine. I don't get a check engine light and I'm not sure if he tried reading codes.

Well if he has seen it before i'll give him the benefit of the doubt..Has anyone else here have this same problem?

speakerboy38 03-23-2010 09:57 PM

Re: 2005 wk 3.7 Starting issue
 
Thank you Gossamer and everyone else who tried to help. I love this forum!

JTK1130 03-24-2010 07:00 AM

Re: 2005 wk 3.7 Starting issue
 
Quote:

Originally Posted by speakerboy38 (Post 175229)
Thank you Gossamer and everyone else who tried to help. I love this forum!

No Problem, anytime.


All times are GMT -5. The time now is 02:25 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community