Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Interior/Exterior Visual (http://www.jeepgarage.org/f136/)
-   -   engine install issues (http://www.jeepgarage.org/f136/engine-install-issues-8036.html)

ekaz 03-30-2010 02:29 PM

engine install issues
 
So, I'm installing a new engine and after a few "ahem", "challenges" we were finally ready to put the heads on. Passenger side dropped in just fine, however, the drivers side header is resting on the steering shaft. :(
Any ideas on why they don't fit all of a sudden?
I loosened and jacked up the driver side to mount the head to get an idea of how out of whack things are. Here's the driver side after I tried lowering it back down:
http://gallery.me.com/erkaz/100006/D...12699748830001
Passenger side mounted for reference:
http://gallery.me.com/erkaz/100006/P...12699749090001
Where the header hits the steering column:
http://gallery.me.com/erkaz/100006/H...12699749410001

Any and all suggestions would be more than greatly appreciated.

Chaoul1 03-30-2010 02:37 PM

Re: engine install issues
 
What size Engine did you drop in a 440?

ekaz 03-30-2010 02:42 PM

Re: engine install issues
 
426...still the same block size.

robpp 03-30-2010 02:58 PM

Re: engine install issues
 
doesnt make sense, like you say, same block.

cant really see but what if you remove header, after its in, does it look like it still hits steering column? in other words, is the header only stopping install or does it look l9ike it will never work?

Black Ops Auto Works 03-30-2010 03:07 PM

Re: engine install issues
 
Just throwing this out their is the block sitting right? It might be tweaked a tad towards the drivers side.
Just something to check!!

hops23 03-30-2010 03:25 PM

Re: engine install issues
 
The thing is that the heads and headers going on the 426 was on his stock block and had no fitment issues before. Can't figure it out either.

Black Ops Auto Works 03-31-2010 07:53 AM

Re: engine install issues
 
Any updates?

hops23 03-31-2010 10:51 AM

Re: engine install issues
 
Motor mounts were on the wrong sides. Even after following manual and extra research, an LX member pointed this out.

Scottina06 03-31-2010 11:04 AM

Re: engine install issues
 
I knew it would be something simple....LOL

Black Ops Auto Works 03-31-2010 01:44 PM

Re: engine install issues
 
Quote:

Originally Posted by hops23 (Post 179803)
Motor mounts were on the wrong sides. Even after following manual and extra research, an LX member pointed this out.

Yep that will do every time.

SoCalMoparWK 03-31-2010 02:21 PM

Re: engine install issues
 
No issues now!! Can't wait to see the Video.


All times are GMT -5. The time now is 01:08 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community