Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   need help!!!!!! (http://www.jeepgarage.org/f5/need-help-8057.html)

copley2596 03-30-2010 10:28 PM

need help!!!!!!
 
i have a 2005 grand cherokee limited with a 4.7l v8. i am recently converting back from a hemi swap gone bad. i now have the new 4.7l out of another 2005 grand cherokee in and when i try and turn it over i just get a click from the starter. and it turns the flywheel wheel about an inch and the fuel pump is getting power cause it is getting fuel to the engine. ANY HELP IS APPRECIATED ITS BEEN DOWN FOR 11 MONTHS........................................

Scottina06 03-30-2010 10:42 PM

Re: need help!!!!!!
 
I assume youve tried all the easy stuff??? Battery, alt, starter etc?

Marlin 03-30-2010 10:46 PM

Re: need help!!!!!!
 
Quote:

Originally Posted by Scottina06 (Post 179622)
I assume youve tried all the easy stuff??? Battery, alt, starter etc?

^^^ what he said. I'm also assuming you checked your "new" engine isn't seized?

robpp 03-30-2010 10:47 PM

Re: need help!!!!!!
 
if the battery has been down for 11 months then start there.
next starter relay then starter.

copley2596 03-30-2010 11:47 PM

Re: need help!!!!!!
 
brand new battery, just put it a brand new starter couple hours ago, checked all fuses in the box, than i put a 13/16 socket on the crank and turned it all the way around. the starter clicks than turns the fan and belt a couple inches and quits. does this everytime i try and turn it over. do u think it could be bad grounds on the block?? or ecu problems?? thanks guys for the help been a stressful year.

hemi.jon 03-30-2010 11:58 PM

Re: need help!!!!!!
 
was ur brand new bat tested? i just got a yellow top from DA the other day and the cells were so low i couldnt even jump it. took it back to test and the bat was toast..might want to double check, it really sounds like a battery issue

copley2596 03-31-2010 12:01 AM

Re: need help!!!!!!
 
everything works great both inside the vehicle and out. all lights stereo and everything come on great even tried jumpin it. and yea it was it is a brand new from les schwab.

Scottina06 03-31-2010 12:31 AM

Re: need help!!!!!!
 
what kind of pcm is in it? Your old pcm or the one from the vehicle that this engine came from?

copley2596 03-31-2010 01:07 AM

Re: need help!!!!!!
 
My old one. When i bought the new used 4.7 it was just the block heads and intake. So i swapped the water pump, fan assembly, alternator, a/c condensor, air intake, wire harness, and pcm from the old motor.

copley2596 03-31-2010 01:08 AM

Re: need help!!!!!!
 
you think i should just take the old pcm into jeep and have them test it and reflash it.

Scottina06 03-31-2010 01:15 AM

Re: need help!!!!!!
 
yes...but I would double check all the connections FIRST. When we did the motor swap on mine...one little unconnected sensor kept throwing codes. we missed it 3x.....

Marlin 03-31-2010 01:16 AM

Re: need help!!!!!!
 
I'm trying to understand mate. Is the starter struggling to turn the engine or is the starter disengaging?


All times are GMT -5. The time now is 01:56 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community