Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   P0420 on an 01 WJ with 85K miles, help? (http://www.jeepgarage.org/f203/p0420-on-an-01-wj-with-85k-miles-help-8352.html)

dhillon09 04-07-2010 09:25 PM

P0420 on an 01 WJ with 85K miles, help?
 
So I had a paper due today at 11:30, i finished at 10:30 and my school is an hour's drive away, so I kinda had to push my truck a bit (I arrived at 11:10, 20 minutes early). Everything was fine, the only weird thing was that my cutout got stuck and wouldn't close until I turned off my truck, but that was no biggie.

So I hand in my paper, with a mild stiffy left from the rather enthused WOT driving in my WJ (My school is ontop of a mountain, for those of you familiar with Simon Fraser University Burnaby, so I was going WOT up a mountain road heh :) ).

So I get back to my truck with a giant smile, jiggle my cutout open and shut and it finally closed (I think the switch is shot/gummed up). Start up and all is well, I'm coasting down the mountain and everything was fine. I got on the highway and started driving and about halfway home I got a CEL. I got to a redlight and did the key cycle, and got code P0420. I searched it on my blackberry and got Cat error so I didn't really care (You think I care about emissions? I drive a v8 truck with the aerodynamics of a brick wall). But anyways, what could it be?

I have a brand new cat (well newer) by Magnaflow (The high flow model) that I installed last year with the rest of my Kolak exhaust. What could it be? I talked to Kolak and he suggested a $100 precat replacement by magnaflow ... what would be my best bet? Thanks in advance guys, sorry for the long post, I just wrote an English paper so I'm feelin' wordy!

josef15111 04-08-2010 08:53 AM

Re: P0420 on an 01 WJ with 85K miles, help?
 
hey there,
more than likely it is your pre cat going bad. i would just recomend cuting both of your pre cats off and running a peice of 2 inch pipe in there place. I just did this around a few weeks ago. i did get that same cel for about 2 days then it went away. it isnt going to hurt anything with the cel on its just there to show you that your down stream o2 sensors are seeing the same amount of gases as y9our upstream o2's. there is a cheater trick to trick the downstream o2's and its a cheap fix... i was told about it by a member on here i will be doing this if my CEL comes back on.
You will like the lil power gain of the pre cats being gone too,


here ya go read post #6 about the foulers...... http://www.jeepgarage.org/f51/removed-the-pre-cats-7522.html

dhillon09 04-08-2010 10:55 PM

Re: P0420 on an 01 WJ with 85K miles, help?
 
BUMP! I went to install my HID's today and my fogs dont work. My foglights don't work with the stock bulbs either but the ballasts are 100% A-okay ... does anyone know where the fuse is for the foglights on a 2001 WJ limited? Bit confused, google gave me nothing


ergg nevermind I'm retarded,

http://www.wjjeeps.com/misc/jblock_main.jpg
F24 15 Amp Lt. Blue Foglamps

josef15111 04-09-2010 09:17 AM

Re: P0420 on an 01 WJ with 85K miles, help?
 
Quote:

ergg nevermind I'm retarded,

ITS NOT NICE TO SAY RETARDED!!! LMAO j/k

Any ways man did you figure out your issue with the fogs? was it your fuse??


How about the cats you have a plan on what you wanna do with them? remove or new?

dhillon09 04-10-2010 11:36 AM

Re: P0420 on an 01 WJ with 85K miles, help?
 
Quote:

Originally Posted by josef15111 (Post 185773)
ITS NOT NICE TO SAY RETARDED!!! LMAO j/k

Any ways man did you figure out your issue with the fogs? was it your fuse??


How about the cats you have a plan on what you wanna do with them? remove or new?

Effing foglights man. What happened is I left my parking brake on 1 notch to bypass the DRL's, and I gues while I was at school someone drove my truck and turned the parking brake off, causing both fuses for my front low beam HID's to burn out, and my foglight fuse was already previously burnt out. Needless to say, today I'm going to rip the console apart and ground the emergency brake cable, and then pull the red bulb from the dash.

I will get pics as soon as I'm done! I took apart and completely resealed my fogs and headlights so it was a pita.


All times are GMT -5. The time now is 04:56 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community