Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   2008 WK REQ Radio Issues - No Sound at times (http://www.jeepgarage.org/f181/2008-wk-req-radio-issues-no-sound-at-times-8364.html)

scottmarion 04-08-2010 10:40 AM

2008 WK REQ Radio Issues - No Sound at times
 
I have a 2008 WK with Radio issues. Factory REQ Radio. At times when the vehicle is started, there will be no sound coming from the speakers. All Radio functions will work though; Change between AM/FM/SAT, AUX, and all info will appear as well like the song info etc. It will come back after a few restarts of the vehicle. I have had 2 radios replaced, ECM module replaced and the issue still occurs.

Does anyone know of what this may be or any fixes that may be out there?

Thanks for all of your help!

DJ BoNiOmArIo 04-08-2010 11:39 AM

Re: 2008 WK REQ Radio Issues - No Sound at times
 
wiring harness is my best bet let Matt chime in and see if he can help

B.P.O.D 04-08-2010 11:40 AM

Re: 2008 WK REQ Radio Issues - No Sound at times
 
hmmm that's odd. i had my radio for a year and never had an issue, is the truck still under warranty??? if so bring it to the dealer!

08Hemi 04-08-2010 11:52 AM

Re: 2008 WK REQ Radio Issues - No Sound at times
 
you said you have had 2 replaced? more than likely it is under warranty...has the dealer been helpful at all?

scottmarion 04-08-2010 01:04 PM

Re: 2008 WK REQ Radio Issues - No Sound at times
 
They have been very helpful and done all replacements. Its stil got a year or 6,000 miles for the warranty. They just cannot find the real root cause. just hoping someone here might know something else.

08Hemi 04-08-2010 03:21 PM

Re: 2008 WK REQ Radio Issues - No Sound at times
 
do you have the BA amp? my first thought would be to take the dash off and take a looksie at the wiring (very easy to do, takes about 15 mins, instructions on wkjeeps.com)...from there you can inspect the connections/wiring harness. Since you know it is not the unit itself (again, I am assuming that all 3 you have had were not faulty) I would inspect the harness as closely as you can. Something is causing the radio to NOT send a signal to the speakers...but the unit itself is functioning...when it is on do you get ANY feedback from the speakers?

Matt 04-08-2010 03:26 PM

Re: 2008 WK REQ Radio Issues - No Sound at times
 
Yeah, I mean it's process of elimination.

Harness
Radio
Wiring
Amp
Wiring
Speakers


Obviously it can't be the speakers or the wiring from the amp to the speakers.

And you said you've had the radio replaced, so that's out.

It's got to be the harness (power side) or the amplifier... or the wiring between those two (which I doubt). The last thing I expect to fail is wiring, the first thing I suspect is the actual electronics.

As Brad said, make sure all connections are snug.


All times are GMT -5. The time now is 07:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community