Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   Hard accelerating problem (http://www.jeepgarage.org/f196/hard-accelerating-problem-9085.html)

oujea 05-03-2010 10:48 AM

Hard accelerating problem
 
Hello

My problem happens only in first gear when starting hard from a dead-stop, and also when moving 20-30 mph and then press gas pedal hardly. Then Jeep is jumping and vibrating 2-3 seconds or until I let off gas... I posted video of my rear driveshaft, is everything ok here?:

zSHARE - Video-0007.mp4

P.S. Sorry for my bad english : )

DJ BoNiOmArIo 05-03-2010 02:47 PM

Re: Hard accelerating problem
 
what year? what type? engine?

that might help us steer u in the right direction

oujea 05-03-2010 03:25 PM

Re: Hard accelerating problem
 
its 2000 year grand cherokee laredo, 4.0 L6 engine, 42re transmission and selec trac transfer case.

DJ BoNiOmArIo 05-03-2010 03:34 PM

Re: Hard accelerating problem
 
hopefully one of the WJ guys can chime in but in mine it was the TCM and torque management system

oujea 05-03-2010 03:38 PM

Re: Hard accelerating problem
 
I'm jeep noob :D so can you explain me detailed where are these parts located and what's their role?

02 WJ 4.7 V8 05-03-2010 06:34 PM

Re: Hard accelerating problem
 
yo bro i had a similar problem with my jeep but i have the 2002 4.7 but anyway when i was driving i would have horrible acceleration so what i eventually did was clean my throttle body and also clean my IAC senors which is on the throttle body.. im not totally positive this could fix your problem but its very easy to clean and who know this could be a simple fix


All times are GMT -5. The time now is 12:23 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community