Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Late transmission engagement (http://www.jeepgarage.org/f203/late-transmission-engagement-9118.html)

Frango100 05-04-2010 10:58 AM

Late transmission engagement
 
When selecting my transmission into R first time of the day or after many hours parked, it takes about 10 sec for the transmission to engage. I had red about a faulty checkvalve in the spin-on charge filter on previously used filters. Changed the filters/fluid a little bit more then a year ago (approx 30K km). Is this still a common thing to happen with this transmission, or do i have to look into some internal leakage? (545rfe)
__________________

DJ BoNiOmArIo 05-04-2010 11:01 AM

Re: Late transmission engagement
 
I'm not sure bout the WJ but in my WK that lage engagement is caused because of the shifter top assembly unit.

just throwing it out there hope that can be a start point

Hemi WK 05-04-2010 12:42 PM

Re: Late transmission engagement
 
The WJ that I had did that and my WK does it too. The WK is even worse than the WJ was. I have taken it to the dealer at least 3 times now and all they do is change the fluid/filters but it hasn't helped.


All times are GMT -5. The time now is 07:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community