Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   WJ 4.7 2000 starting probs when cold (http://www.jeepgarage.org/f196/wj-4-7-2000-starting-probs-when-cold-9542.html)

pitman1031 05-17-2010 11:48 AM

WJ 4.7 2000 starting probs when cold
 
Does anyone have any ideas why my WJ 4.7 takes around 5 seconds of cranking when cold before the engine starts and then runs perfectly. This car has done 114000mls and is fully serviced.:confused:

StoneCold 05-17-2010 03:10 PM

Re: WJ 4.7 2000 starting probs when cold
 
Could be dirty IAC valve, throttle body needing cleaned. I cleaned both of mine and that stopped the problem:thumbsup:

I imagine if it's been fully serviced it's not the spark plugs, but you never know.

Only other thing coud be fuel pump or filter.

Try turning the key to full on, so the dash lights up, but don't actually start it, wait a couple of seconds and start it. If it starts ok, it's possibly fuel pump. I'm sure there's an o ring in the pump that can go bad.

pitman1031 05-20-2010 03:41 PM

Re: WJ 4.7 2000 starting probs when cold
 
I dont think its the fuel pump oring as leaving the ignition on makes no difference, where's the IAC valve situated ?

StoneCold 05-20-2010 04:04 PM

Re: WJ 4.7 2000 starting probs when cold
 
It's on the lower right side of the TB. Just disconnect the plug and take out the two screws (torx T20).

I posted something about this before, hang on I'll go look for it:thumbsup:

Found it, just scroll down to the pics

http://jeepgarage.org/showthread.php...701#post189701

Should be good to go at that.


Aaron

Frango100 05-20-2010 05:58 PM

Re: WJ 4.7 2000 starting probs when cold
 
Leaving the ignition on for more then a few seconds with the engine off will not make a difference, because as soon as the ignition is turned on, the fuel pump starts for 3 seconds and shuts off, until you start the engine. If the O'ring is really bad, waiting longer will only reduce more the fuel pressure. Maybe you can switch the ignition on for 3 seconds, switch it off and on again and try to start quickly. But only a fuel pressure test will show you if the pressure will stay (as it should for quite some time) , or drops quickly, which could be the O'ring of the fuel pump, or the fuel filter/pressure regulator.

pitman1031 05-21-2010 11:34 AM

Re: WJ 4.7 2000 starting probs when cold
 
Thanks boys I am on it..


All times are GMT -5. The time now is 08:16 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community