Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Exhaust Question?? (http://www.jeepgarage.org/f5/exhaust-question-9627.html)

rufdod 05-19-2010 09:22 PM

Exhaust Question??
 
When i first got my jeep about a year and a half ago, the first thing i did was exhaust. I had it done at a local shop, i believe they put in a flowmaster 50 series or w/e. And coming out the back on the right side it Y'ed off into 2 3" stainless tips. (if that makes sense)

So fast forward to last friday, i had them redo my exhaust similar to the SRT style with Thermal R&D 5" dual wall slant cut tips. All they did was bend new pipe to come out the middle of the jeep and used some sort of Y to attatch the Tips.

I believe the pipe size is all 2.5" or 3" I think its 2.5"
And its not dual exhaust it goes 2-1-2 tips

So since i have had it back, around 1100 rpm my jeep makes really weird noise and maybe some vibration. Then it does it again around 3k rpm, Its almost like a sound right before you stall out.

If anyone has any idea what this is let me know, The only thing i can think of is the bigger tips dont provide enough back pressure?? I really have no idea? It does seem to be alot louder too, although this could be the different placement of it , but i do think its louder.

SvenskaJeepGuy 05-19-2010 09:24 PM

Re: Exhaust Question??
 
could it be the pipes hitting something under the car? my exhaust is 3" all the way through and i dont have that problem so it isnt the pipe size.

rufdod 05-19-2010 09:27 PM

Re: Exhaust Question??
 
idk, it only does it at those rpms like when your not really on the throttle.. They did mount the mounts to the hitch... but thats the only difference, if there were the problem i would think it would do it more often..

rufdod 05-19-2010 09:28 PM

Re: Exhaust Question??
 
the pipes def arent hitting anything but maybe its how they mounted the brackets

jeepgcoman 05-19-2010 10:28 PM

Re: Exhaust Question??
 
When they mounted the exhaust to the hitch did they mount them in rubber, or direct to the hitch?

rufdod 05-19-2010 10:41 PM

Re: Exhaust Question??
 
rubber, like usual, thats the other reason i didnt think it was a mounting issue

SvenskaJeepGuy 05-19-2010 11:54 PM

Re: Exhaust Question??
 
there is a heat shield under the vehicle made out of cheap tin, maybe it is catching that when you push on the throttle?

rufdod 05-20-2010 09:29 AM

Re: Exhaust Question??
 
i will look at that, but the only thing new is basically from the axle back, IDK it is really frustrating though. I also though maybe it was something else going wrong, and just a HUGE coincidence that it started when i got my exhaust done...?

Chaoul1 05-20-2010 09:44 AM

Re: Exhaust Question??
 
Take some pictures of the exhaust. Get someone to push on the throttle and look underneathe to see what's going on.


All times are GMT -5. The time now is 02:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community