Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Transmission leak/slip (http://www.jeepgarage.org/f203/transmission-leak-slip-9765.html)

Unholyskorn86 05-25-2010 09:36 AM

Transmission leak/slip
 
OK, on to the next problem. Arggg. My Jeep has been slipping on left turns for a while now. I finally came to the conclusion that maybe it was low on fluid and sloshing around while taking these left turns. I put half a bottle of atf4 in her before going home last night and woke up in the morning with a decent football sized puddle of atf4 on the ground. Now, it did not leak before I put this in. The slips def. went away when I added the fluid. What do you guys think? Do I have a leak? Did I just overfill it and it poured out? If I do have a leak, where does it sound like it's coming from for it to do it only after being filled? How much does this cost to repair? Tranny runs great.... Thanks for the help!

josef15111 05-25-2010 12:28 PM

Re: Transmission leak/slip
 
i would try and look around the trannsmission pan seal to see if it is busted out or maybe even you have some missing screws, or loose one. you should be able to see what the ffluid is coming from if it is leaking like that. also look at the tail end of the tranny to see if it is coming from the rear seal. you could even go as far as putting adye in there and getting a blacklight to see where it is leaking from. your slipping does sound like it is related to your oil being low have you checked it? warm her up and run threw the gears and check the stick with it running "im sure you all ready know" see what it says. let us know and hope it helps..

Unholyskorn86 05-25-2010 02:43 PM

Re: Transmission leak/slip
 
It only started to leak when I added the half quart of ATF4 to it. I already know that adding the half quart to it fixed the slipping problem instantly. I'm asking would it leak like this if I overfilled it? It seems like it drains to a point and then stops leaking. Then a month later it'll start slipping again once the fluid is down to that point and it holds there...

lewi3069 05-25-2010 02:55 PM

Re: Transmission leak/slip
 
Quote:

Originally Posted by Unholyskorn86 (Post 213207)
It only started to leak when I added the half quart of ATF4 to it. I already know that adding the half quart to it fixed the slipping problem instantly. I'm asking would it leak like this if I overfilled it? It seems like it drains to a point and then stops leaking. Then a month later it'll start slipping again once the fluid is down to that point and it holds there...

I don't think it would over flow the transmission. You didn't have any overflow or spillage when filling that you didn't notice?

josef15111 05-25-2010 06:26 PM

Re: Transmission leak/slip
 
No the tranny wouldnt start spewing out fluid if overfilled. i beleave it can only come in and out from the dipstick. or a leak. have you looked under the jeep to see if there is anything you could see?

Unholyskorn86 05-25-2010 07:51 PM

Re: Transmission leak/slip
 
It seems like the fluid is coming out of my transfer case. I am not 100% sure, but looked quick at it and saw a drip coming off the case. Why all of a sudden after adding atf4 to the tranny would the transfer case start leaking? (if it is that)

Frango100 05-26-2010 03:13 AM

Re: Transmission leak/slip
 
It looks like your tranny aft seal is the problem. The fluid dripping from the T-case is most probably the tranny fluid. Did you check the color of the fluid? T-case fluid is normally quite light in color (at least when you use the original one) and the tranny fluid has more of a redish color.

Unholyskorn86 05-26-2010 09:00 AM

Re: Transmission leak/slip
 
Well I replaced the transfer case fluid months ago. But yeah, today when I got in, and also drove it to work and had it sitting there is not a drop coming from anywhere anymore....I'm so confused. Put half a bottle of atf4 in the tranny two days ago....xfer case starts leaking for a day and a half slowly and then stops all leaks....am I missing something?


All times are GMT -5. The time now is 06:41 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community