Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Startup reverse stall? (http://www.jeepgarage.org/f5/startup-reverse-stall-9808.html)

NHWK05 05-26-2010 07:39 PM

Startup reverse stall?
 
Well not really a stall but i noticed that if i start up my jeep from a rest, then quickly put it in reverse and try to backup it just revs the engine and no movement for about 20 seconds after startup. If i do the same thing but let it sit for a about 30 seconds everything is fine.

I seems like there is a lack of pressure in the tranny or torque converter on startup and it needs to build before moving. But this is only in reverse.

My jeep used to stall out after stops and randomly like many other wks but i took a master jeep mechanics advise and added half a qt of trans fluid and its been gone ever since (knock on wood) he said that WKs tend to be low on pressure in the trans making them stall and such.

Anyone else have this reverse issue?

4.7 V8 QT2.

RiverCityWK 05-26-2010 07:58 PM

Re: Startup reverse stall?
 
mine does it in drive.

kycoolcat 05-26-2010 08:12 PM

Re: Startup reverse stall?
 
Hey guys mine does it too. I was reading the service bulletins on this site for 05' and it listed this problem and said a certain tranny filter was to blame. You have 2 different kinds of filters if you take the bottom of the tranny pan off. I think it was the spin on filter. If you go to change it, i think it said get the filter that the part# does not end in AB. Anyway its in the recalls and service bulletins. Mines a 05' 3.7. I don't remember if that went for the other engines. Hope this helps. Later.

rufdod 05-26-2010 11:15 PM

Re: Startup reverse stall?
 
mine does it in drive and reverse somethimes. I have new filters, i guess i just need to change the filters and fluid and stop stalling, see if that helps..

1 GRAND 05-27-2010 08:25 AM

Re: Startup reverse stall?
 
I usually always let my Jeep idle down before moving it, but the few times that I have started it and jerked it in gear it has made a squealing sound like a belt on a riding lawn mower engaging. It just does it for a second then takes off.

kycoolcat 05-27-2010 08:15 PM

Re: Startup reverse stall?
 
Quote:

Originally Posted by rufdod (Post 213807)
mine does it in drive and reverse somethimes. I have new filters, i guess i just need to change the filters and fluid and stop stalling, see if that helps..

thats funny rufdod, i too have the filters. just need to change them out..

bullet700 05-27-2010 09:44 PM

Re: Startup reverse stall?
 
every single thing that was said here happens to my Jeep. It's like it has moods swings, today it does what one of you guys said, then tomorrow it does what another person said here. the real question: WHAT'S TO BE DONE TO FIX THESE? the tranny oil needs fill up? need to change some filter?? IDK!!


All times are GMT -5. The time now is 03:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community