Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Need Help! HID's not working (http://www.jeepgarage.org/f5/need-help-hids-not-working-9910.html)

snewt22 05-31-2010 08:42 PM

Need Help! HID's not working
 
So ive had my HID's for about 6 months now, and if you guys remember we had all kinds of problems at first, but then they finally worked....and have worked since......but 2 nights ago, after they had worked all day, I got in my jeep to go home and my lights wont come on....my brights work, but not my hid's..........anybody know what this could be?

snewt22 05-31-2010 08:44 PM

Re: Need Help! HID's not working
 
and yes I checked the fuse.....not blown, but I changed it just in case..........The guy that installed them had to wire the fog lights with the HID's and all 4 of them are not working......please help

SvenskaJeepGuy 05-31-2010 09:14 PM

Re: Need Help! HID's not working
 
go back to stock lights, it isnt worth the hassle. i would go and check the bolts on all of your grounds and make sure water didnt get in anywhere.

Scottina06 05-31-2010 11:05 PM

Re: Need Help! HID's not working
 
sounds like a fuse or the relay is blown. This is the exact reason you need 2 relay harnesses...one for each light.

Get ya a legit HID kit with relay harnesses and next time your in Lexington...let me know and we'll install them.

snewt22 06-01-2010 02:39 PM

Re: Need Help! HID's not working
 
......u let me drive ur jeep?


All times are GMT -5. The time now is 10:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community