Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 8 of 8
Search took 0.01 seconds.
Search: Posts Made By: jmolli
Forum: Troubleshooting/Problems 11-15-2012, 08:02 PM
Replies: 59
Views: 38,121
Posted By jmolli
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

Mens,

The blinking dash lights and headlights, AC cutting out, etc. is caused by a bad ignition switch. $50 and 45 miniutes of struggle under the dash and its fixed. I had the same problem on my...
Forum: Troubleshooting/Problems 01-14-2012, 12:13 PM
Replies: 1
Views: 2,111
Posted By jmolli
Re-Calibrate Blend Door after Actuator Motor Replacement?

I'm replacing the actuator motor for the AC/Heater blend door on my 05 GC Laredo. Does anyone know if it's necessary to some-how re-calibrate the door travel after installing a new actuator. I'm...
Forum: Troubleshooting/Problems 01-11-2012, 09:15 PM
Replies: 3
Views: 1,699
Posted By jmolli
Re: Rapid HVAC Clicking Noise in Dash When Cold

Jeepguy, Thanks for the reply. I assume you mean the blend door actuator. I will disconnect the lead to the actuator and see if it stops the clicking. I owe you a beer if you called this one...
Forum: Troubleshooting/Problems 01-11-2012, 06:54 AM
Replies: 3
Views: 1,699
Posted By jmolli
Rapid HVAC Clicking Noise in Dash When Cold

I've replaced both the blower motor resistor and it's wiring harness on my '05 WK 3.7L as both had obvious signs of heat damage from shorting. I thought this would solve the clicking noise coming...
Forum: Troubleshooting/Problems 12-26-2011, 12:48 PM
Replies: 8
Views: 1,228
Posted By jmolli
Prestone Coolant Causing Water Pump Problems??

replaced the water pump on my 05 3.7L WK about two years ago at 70,000 miles. The bearings had begun to fail and I had a chattering at idle from the pump pulley. I installed a brand new Mopar pump...
Forum: Troubleshooting/Problems Discussion 12-24-2011, 10:38 AM
Replies: 13
Views: 4,746
Posted By jmolli
Re: have you replaced your waterpump???

Replaced the water pump at 70,000 miles on my 2005 3.7L WK. It had a diesil like sound at idle, it was the bearings failing on the pump. I could shake the pulley easily with my hands. The job is very...
Forum: Troubleshooting/Problems 09-22-2011, 05:54 PM
Replies: 29
Views: 2,497
Posted By jmolli
Re: WK Starting Issue

I had a similar problem with my '05 GC. I replaced the starter and still had the same problem. Basically a click-engage starter-click-disengage ocurred when I turned the key to the start position. A...
Forum: Tech Tips DIY/How To 09-22-2011, 05:39 PM
Replies: 1
Views: 1,342
Posted By jmolli
Brake Grease Packet Leaked on my Akebono Brake Pads!

I ordered a set of Akebono ceramic front pads from Amazon for my '05 Grand Cherokee. Unfortunately the included packet of brake grease was pinched between the pads in transit and leaked grease on the...
Showing results 1 to 8 of 8

 
Forum Jump

All times are GMT -5. The time now is 02:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community