Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 13 of 13
Search took 0.01 seconds.
Search: Posts Made By: ccurrier
Forum: Troubleshooting/Problems 11-24-2014, 10:58 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

IndyGO,
I don't' recall the size but I do remember that after buying the tamper proof bit, I tried with a normal one and it worked fine. The hole was recessed enough that it worked without the...
Forum: Engine Performance/Intake/Exhaust 08-05-2013, 11:06 AM
Replies: 5
Views: 891
Posted By ccurrier
Vivid Linq + Torque reviews/thoughts

Does anyone have a Vivid Linq with their WJ Jeep that can share their experience? I have a couple questions that I haven't been able to find anywhere else.

1. Has anyone tried/used the Vivid...
Forum: Troubleshooting/Problems 08-05-2013, 09:40 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

Yes, that is the part that sits between the Cylinder and the ignition switch. Here is a picture of my part to compare to the new one I posted before. As you can see the rod that goes through the...
Forum: Troubleshooting/Problems 07-29-2013, 07:41 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

Ignition Switch Actuator Pin. That is the name.
Here is what it looks like new.
...
Forum: Troubleshooting/Problems 07-27-2013, 02:27 PM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

Well, got ignition switch replaced and it seemed much better until this morning. I turned the key and it was like it wasn't hooked to anything. I took the cylinder back out, and removed the...
Forum: Troubleshooting/Problems 07-26-2013, 11:28 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

I'm pretty sure the key didn't come out before going to off, but I could be wrong, I'll have to check that out.

I didn't charge the battery all the way before driving. I've always been able to...
Forum: Troubleshooting/Problems 07-26-2013, 07:19 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

Making progress! Retested terminal 87 to starter and it was good. So I reconnected it and tested 12V to 87 and the starter cranked. Must have just been a bad connection at the solenoid when...
Forum: Troubleshooting/Problems 07-25-2013, 07:25 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

No luck, Fuse was good. I took the covers off the steering column last night hoping it was easier to get to the C1 connector you referred to so I could test that. It was a bit deeper in there then...
Forum: Troubleshooting/Problems 07-24-2013, 02:17 PM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

If it is the ignition switch, is it as simple removing steering column covers and replacing this $40 part?
Buy BWD Ignition Switch CS807 at Advance Auto Parts...
Forum: Troubleshooting/Problems 07-24-2013, 11:55 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

Thanks for the tips Frank. I will check fuse 14 and hope it's bad.

Then I'll move on to C1 and post back.
Forum: Troubleshooting/Problems 07-24-2013, 11:29 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

That is what I'm thinking, ignition problem.

I did try applying 12v to 87 and the starter did not engage. This leads me to believe that I might also have a wiring issue between 87 and solenoid....
Forum: Troubleshooting/Problems 07-24-2013, 10:38 AM
Replies: 25
Views: 1,141
Posted By ccurrier
Re: 2003 4.7 starting issue

Current state:
If I disconnect the solenoid terminal wire harness and jump that to the solenoid battery terminal while the ignition is in the run position, the vehicle will start.

Tests...
Forum: Troubleshooting/Problems 07-24-2013, 10:21 AM
Replies: 25
Views: 1,141
Posted By ccurrier
2003 4.7 starting issue

First off I have to say this forum is full of great information, and even greater people. So far I haven't been able to figure out my starting issue, so wanted to see if anyone had some tips or...
Showing results 1 to 13 of 13

 
Forum Jump

All times are GMT -5. The time now is 06:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.