Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 6 of 6
Search took 0.01 seconds.
Search: Posts Made By: A1C2Hi
Forum: Troubleshooting/Problems Discussion 10-20-2013, 11:23 AM
Replies: 3
Views: 424
Posted By A1C2Hi
Re: How to open radiator drain plug

Thanks for your suggestion however I was hoping to first drain the radiator before removing the bottom hose in order to avoid the spillage that will occur when the hose is removed with the radiator...
Forum: Troubleshooting/Problems Discussion 10-19-2013, 03:02 PM
Replies: 3
Views: 424
Posted By A1C2Hi
Unhappy How to open radiator drain plug

I have a 2000 JGC with 4.0 engine. I wanted to drain and flush the cooling system today but could not get the drain plug on the radiator to turn more than a quarter turn to the left. It will not turn...
Forum: Troubleshooting/Problems 10-05-2013, 07:28 AM
Replies: 3
Views: 513
Posted By A1C2Hi
Unhappy Check Gauges Light/Low Oil Pressure

I have a 2000 JGC with 4.0 engine 117K miles and I keep getting the "check guages" light and low oil pressure. When cold the oil pressure goes up to about what would be 50-60 then as the engine warms...
Forum: Troubleshooting/Problems 09-27-2013, 03:36 PM
Replies: 4
Views: 532
Posted By A1C2Hi
Re: Overhead Console Problems

Ok I just finished installing a used overhead console module and everything appears to be working as it should. I have to go recalibrate the compass. I hope this took care of this problem. Thanks...
Forum: Troubleshooting/Problems 09-26-2013, 09:40 PM
Replies: 4
Views: 532
Posted By A1C2Hi
Re: Overhead Console Problems

Thanks for the welcome Frank. I have located and purchased a used console from the same model JGC as mine ($30) in hopes I can just change out the module and fix the problem. Got my fingers crossed...
Forum: Troubleshooting/Problems 09-26-2013, 05:59 PM
Replies: 4
Views: 532
Posted By A1C2Hi
Unhappy Overhead Console Problems

I recently purchased a 2000 JGC Limited, 4.0, 2WD with 117K miles. The overhead console displays the "perform service" message along with the chime at every startup. Pressing the "reset" button does...
Showing results 1 to 6 of 6

 
Forum Jump

All times are GMT -5. The time now is 03:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community